-1
\$\begingroup\$

I am trying to download program from laptop to my Atmega16. For this purpose I am using USBASP. The link for the USBASP is:

https://robu.in/product/usbasp-avr-programming-device-for-atmel-proccessors/?gclid=EAIaIQobChMI5ZvYr7fj2AIVi7XACh0OlQ-tEAQYAiABEgKP6vD_BwE.

However, when I try to transfer code I get following error:

avrdude: warning: cannot set sck period. please check for usbasp firmware update. avrdude: error: programm enable: target doesn't answer. 1 avrdude: initialization failed, rc=-1 Double check connections and try again, or use -F to override this check. avrdude done. Thank you.

Assuming it is micro-controller error I bought a new IC but the problem persist.

Further I tried to slow frequency of program by using -B command in avrdude. It didn't work then I used Jumper wire on Jp3 as given in the manual, still no change.

Please let me know how to proceed further. Wiring from target IC to Programmer is as shown in the images below. enter image description here enter image description here

Regards Srinidhi

\$\endgroup\$
0
\$\begingroup\$

The part you're programming needs to be powered and decoupled properly. Simply connecting one of the VCC pins isn't sufficient.

Depending on what fuse bits you have set, you may also need to connect a clock crystal or external oscillator.

Additionally… the microcontroller you're using looks suspicious. I don't see any markings at all on its surface. Are you sure it's actually an AVR?

\$\endgroup\$
  • \$\begingroup\$ I am doing it for the first time. Can you please explain how to power target IC. Also the usb programmer I am using supplies 5v power so if I externally power the target IC will it not burn? \$\endgroup\$ – Shrishailan Srinidhi Jan 31 '18 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.