0
\$\begingroup\$

I'm currently doing a very complex circuit board in eagle.

Currently I defined 7 classes of which 6 I am using. the seventh I want to delete since I no longer need it.

First I tried the command "class -n" to delete the class where n is the class number I want removed, and I got the error "Net class n is in use"

Then I did some research at: https://www.element14.com/community/thread/47449/l/highlighting-nets-and-colours-for-net-class-es?displayFullThread=true

So I am in my board, executed the cmd-change-class.ulp script, then I put in the correct values for the options:

I specified for current class in board the one I want to remove

I specified "default" for the "change class to" field

I specified mm for grid since that's what I am working with

Then when I clicked OK, the box simply disappeared and I got no indication as to whether the operation was successful or not.

So then I tried again to remove the same net class again as before and I still get the same error: "Net class n is in use"

Rather than highlighting the entire circuit and changing the class to one class (and wrecking my class settings for other nets), what is a simple solution to this problem?

\$\endgroup\$
  • \$\begingroup\$ Have you tried going to "Edit->Net Classes..." and simply deleting the entry in the "Name" column? That should delete the class. \$\endgroup\$ – Tom Carpenter Feb 11 '18 at 22:12
  • \$\begingroup\$ Failing that, run the statistic-brd ULP and see what signal(s) is using the class by going to the "Class" tab on the statistics window and selecting class 7. \$\endgroup\$ – Tom Carpenter Feb 11 '18 at 22:14
  • \$\begingroup\$ Sad truth is both your ideas failed. The first idea still gave me the error that the class is in use and that the name cannot be empty. The second idea literally froze my machine the moment the stats screen appeared (all I was able to do was press the power button to do a normal shutdown) \$\endgroup\$ – user152879 Feb 11 '18 at 23:27
  • \$\begingroup\$ Hmm. If it isn't a super secret design, could you upload a copy of the brd/sch to here? \$\endgroup\$ – Tom Carpenter Feb 12 '18 at 7:41
  • \$\begingroup\$ If you want to check if this is a bug, make a copy and do the conversion you talked about. Chances are that may fail too \$\endgroup\$ – PlasmaHH Feb 12 '18 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy