8
\$\begingroup\$

I've implemented a water level indicator using a 555 timer. It works fine when I use 555N, but the output is always high when I replace it with 555P. I don't understand.

I have tried four 555Ps to rule out the possibility of a faulty IC, but it still doesn't work. Meanwhile 555N works (I've checked with two ICs).

I googled it and found that there is virtually no difference between them. So, why is this happening?

Link to falstad circuit

Circuit diagram:

Water level indicator - circuit diagram

This 555N works:

555N

This 555P doesn't work:

555P

\$\endgroup\$
  • 1
    \$\begingroup\$ Make a test circuit not involving water. \$\endgroup\$ – Eugene Sh. Feb 21 '18 at 17:20
  • 1
    \$\begingroup\$ I did that. I shorted VCC and RESET to test it without water. It works with 555N but not 555P. \$\endgroup\$ – Ashish Ranjan Feb 21 '18 at 17:21
  • 13
    \$\begingroup\$ I am getting downvoted here without really an explanation. Andy and Trevor gave me some direction to proceed in their answers. I am really thankful to them for this. However, people in the comments are just saying the circuit is bad without explaining why. You know what, I understand there is something bad with the system. I didn't know what? That's why I asked the question. I mean, I don't have a problem with downvoting the question, but please first provide me an explanation why? I was struggling with this for the past week. I really sorry for this rant, but this made me very uncomfortable. \$\endgroup\$ – Ashish Ranjan Feb 21 '18 at 18:03
  • 4
    \$\begingroup\$ I think the attitude was probably what led to any downvotes you may have gotten. You repeatedly argued with people saying "but it worked on one of them". I would have posted an answer but Trevor's pretty much covers what I was going to say. Not all chips are made equal, even ones with effectively the same functions and names. \$\endgroup\$ – DerStrom8 Feb 21 '18 at 18:55
  • 2
    \$\begingroup\$ Thank you so much @jsotola for taking your time to provide me with the resources! I'll most definitely try this and let you know the results :) \$\endgroup\$ – Ashish Ranjan Feb 21 '18 at 20:02
24
\$\begingroup\$

In general, when a circuit works with a device from one maker and not from another it is telling you is that your design is incorrectly using some feature of the device on the verge of the design characteristics.

In this case how you are driving the reset pin.

That is a bad thing. You say it works with a 555N, but I am willing to bet if you tested enough 555N samples, only a proportion of them will work. So be glad you tried the other part.

Fix your design so the reset pin gets what it really needs, i.e. a digital level not an analog voltage that hovers somewhere between the logic thresholds as defined in the worst case 555N/555P data-sheet.

You likely need to add a simple comparator circuit, with hysteresis, to do that.

\$\endgroup\$
18
\$\begingroup\$

Your design is flakey.

You are using the conductance of water to trip the reset line and this is not a great idea given that the reset pin current (the leakage current from the reset pin) is in the realm of 0.1 mA to 1.5 mA depending on the voltage state of that pin. Read the DS.

So, if it is producing 0.1 mA (ignoring the water sensor effect), this passes through a 10 k resistor to ground and produces a voltage of 1 volt. If the current is twice as high it will produce 2 volts etc..

Given that \$V_{RESET}\$ (i.e. the voltage at which a reset occurs) is typically 0.7 volts, you are in trouble with this design and you need to lower the 10k resistor.

enter image description here

The water sensor can only add voltage to the reset pin so this doesn't help.

Maybe one device inherently produces a lower reset pin leakage current and this happens to work on the NE555N device you have tested. As far as I can tell, you have a bad design and it may work with one chip but it certainly can't be expected to work with different supplier's chips.

Try a redesign and don't think that it must be a good design if it works on chip A.

\$\endgroup\$
  • 1
    \$\begingroup\$ I will try with a different circuit and share my observations. \$\endgroup\$ – Ashish Ranjan Feb 21 '18 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.