1
\$\begingroup\$

I'm trying to make a DC motor, but it won't run and I suspect the issue is the windings. When 12v is passed through, they're magnetised but move only a few millimetres, and only if they're in certain positions. Everything's connected right, the current is definitely passing through, and the stationary magnets are big and beefy. I used 0.4mm copper wire, 350 coils around an iron core, 3 total connected in series to a split commutator. There's no load, so nothing that really could be stopping it.

So far I've tried different strength stationary magnets, different positioning of the stationary magnets, different voltages, different brushes, readjusting the commutator. At this point I'm almost certain that the armature is the problem. This could be very very wrong, but could it be that doing 350 coils means a resistance so high the electromagnet won't work? I really don't want to rewind everything again if there's not something else that might be the issue?

edit/update: First some extra information, yup, they're magnetised in the right direction. The brushes are energising the coil at the top - I thought that was the right one to get the most torque?? I've tried spinning it to get it started but it still peters out millimetres afterwards.

And then the update: The current was passing through the wire into the core. The threads of the screw must have cut into the wire. So I decided to rewind the whole thing anyway. Hopefully attempt 2 works better?Here's try number 1; is there anything else fundamentally wrong?

update 2: rewound so current isn't passing through core. It's working slightly better now, maybe a cm of movement? I'm seriously stymied though because I was counting on that being the issue.

update 3: the magnets are as close as possible without hitting the bolts each revolution. They're about 5 cm higher than the hole, so possibly too high? The coils definitely are producing some magnetism, a compass is changing when I hold it next to the energised one, I just don't think it's enough. I'm now playing around with the commutator and brushes to see if I can adjust something.

update 4: changing the order of the commutator seems to have helped some. Though they're not in the picture I do have two field magnets but now I'm pretty sure they're too small (pole is about 1cm x 1.5cm) so I'll try to get bigger ones tomorrow. There's 3 electromagnets spaced 120 degrees, sorry for the poor picture. I'll add a new one with new magnets. The commutator is intermittently sparking if I manually turn the shaft, I'll try to fix up the ends tomorrow too.

enter image description here

enter image description here

enter image description here

\$\endgroup\$
  • 2
    \$\begingroup\$ Let's have a photograph. 'Trying to make' could mean you're sticking cocktail sticks into corks, or have turned/milled a precision piece of kit. Let's see which before we make a call on what could be wrong. Using my 'far-seeing-eye', I would imagine your airgap is too big, so your torque is too low to overcome cogging from an unbalanced mechanical construction (just like the motors I attempted to make). \$\endgroup\$ – Neil_UK Feb 22 '18 at 7:38
  • \$\begingroup\$ How many poles does it have : if only two then it won't self start... \$\endgroup\$ – Solar Mike Feb 22 '18 at 7:40
  • \$\begingroup\$ they're magnetised ... in the correct direction? \$\endgroup\$ – jsotola Feb 22 '18 at 8:01
  • \$\begingroup\$ Also, check that the brushes are energising the correct coil at any instant. This should be the one in the plane of the magnetic field / the wires closest to the magnets. \$\endgroup\$ – Transistor Feb 22 '18 at 8:09
  • 1
    \$\begingroup\$ (1) How many coils are on the rotor? I can only see two at right angles although there seem to be wires for four. (2) We can't see the magnets. Do you have a magnetic circuit connecting the back of the magnets together? Add a photo with the magnets in position. (3) Are your brushes shorting everything out on transition from one contact to another? \$\endgroup\$ – Transistor Feb 22 '18 at 12:36
1
\$\begingroup\$

There are a few obvious things to fix here:

  1. Use better bearings! That large diameter just rubbing against what looks like a plastic sleeve must have significant friction. Cut the red pipe shorter and have something much thinner come out the ends. Even a nail sticking out going into a nylon eyelet with a little bigger inner diameter than the nail should be lots better. A drop of oil in each bearing would help too.

    You should be able to give the shaft a quick twirl with a finger, and have it take a few seconds to coast to a stop.

  2. You need field magnets. A motor works due to magnetic forces between the rotor and the stator. You have magnets on the rotor, and they seem to be commutated, but there is no magnetic field for these magnets to experience force against.

    Since you are commutating the rotor, you only need fixed magnets for the stator. Properly placed permanent magnets would work.

  3. Make sure your rotor magnet arrangement makes sense. This is a particularly poor picture because we can't see the rotor magnetic arrangement. The simplest would be three electro-magnets spaced equally apart. The picture looks like there are two at right angles. That by itself is not a good strategy. Perhaps the two you show are 120° apart and a third one is hidden. That would be OK, but again, your picture does not make that clear.
  4. Make sure your commutation is correct. Once you have proper stator magnets, you can check this by slowly rotating the shaft and feeling when the rotor tries to pull in what direction.
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.