1
\$\begingroup\$

Intro: My Colleague and I have been using altium Designer for Sometime now . Currently AD 17.1.6 (build 538) . The PCB we draw are 3d 4 layer maximum . the only difference between us is that the smallest grid I use is 0.1mm , while he uses the finest Grid 0.025mm.

Problem: when my Colleague is using Design Rule check it is taking for every to be done ( about 30 minutes ) . while my PCB which is comparable in number of components nad size takes about 30 seconds on the same Computer !!

My thoughts: I am trying to analyze the problem and i have come up with 2 possible causes :

  1. The Fine Grid is causing the program to make more calculations causing it to take more time , can anyone confirm/comment on that ??

  2. The 3D objects placement and clearance is causing the software to consume the extra time (unlikely) , but does anyone know a way to prevent the DRC from looking for violations in certain rules ? so i can go one by one and eliminate until i find most time consuming rule.

If anyone is wondering about the PC : it is a core i5 processor, with 8Gb ram and GTX 660Ti VGA.

\$\endgroup\$
  • \$\begingroup\$ check if the PC specs are within the recommended the VGA seems decent but quiet old . You could also try altium designer 18 (64bit) . it promises faster performance if you can live with bugs. \$\endgroup\$ – Sarah Feb 23 '18 at 15:44
  • \$\begingroup\$ Just disable the rules you don't want to be checked. \$\endgroup\$ – The Photon Feb 23 '18 at 15:49
  • \$\begingroup\$ And don't use fully detailed 3D models for complex parts; a simple box or cylinder model is often enough to check for collisions. \$\endgroup\$ – The Photon Feb 23 '18 at 15:51
  • \$\begingroup\$ can you tell me how to disable the rules that i donot want to be checked , is it from the tools menu : Design Rule Check , or is it from the Design menu , Rules tab ??? \$\endgroup\$ – ElectronS Feb 23 '18 at 15:54
  • \$\begingroup\$ I've had decent luck sending design files to Altium tech support for these questions. There are a number of "features" that can lead to crazy slowdowns - In my case, it was generating extra " stacked" primitives, every arc was duplicated 3- 4 times. \$\endgroup\$ – Selvek Feb 23 '18 at 16:06
2
\$\begingroup\$

Start by selecting only the important rules that you want checked. The first step would be to ensure that you do not have an excessive number of rules set up in your Design -> Rules settings. Once those are cleared out you can go to Tools -> Design Rule Check and change the settings for each element under the Rules To Check heading in the left panel.

Additionally, in the Design Rule Check window change the "Stop when ___ violations found" to something manageable (for example, 100).

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.