Alright, this is my first time posting on electronics.stackexchange.com but I have frequented stackoverflow.com for some time now. Basically I am trying to output serial data from the Arduino to an iPhone. I installed OpenSSH on the iPhone, and starting minicom from the ssh session. I have a simple Arduino sketch outputting Hello World. So I thought I would see Hello World in minicom window but I don't.

My minicom window looks like the following enter image description here Yes, the baud rate of the Arduino sketch and minicom are both set to 9600. If you look in the lower right you will see that minicom states that it is "offline" so I am wondering if this is my problem.

My arduino sketch code looks like the following:

void setup()
{
Serial.begin(9600);
Serial.println("Hello World");
}

void loop()
{
}

The solder joints on my iPhone dock connector look good, and I think I breadboarded everything correctly, so I don't understand why I am not seeing Hello World in minicom.

Here is a picture of the dock connector enter image description here

Here is a picture of the breadboard enter image description here

Update on June 07. Well I tried a couple of things and still no luck. I created a google doc that I will try and keep updated with my progress, it can be found here.

  • Could it be permissions on the /dev/tty? stackoverflow.com/questions/9653692/… – Martin Thompson Jul 18 '12 at 10:49
  • Really great question! The offline could be imporantant.. maybe you need to send RTS? also iPhone needs to gointo this Serial Mode somehow does it not- and each version has some newer and more difficult way of doing that. Can you add some references for design? I would love to look into this too. – ppumkin Jul 18 '12 at 11:12
  • OK well i found this.. devdot.wikispaces.com/Iphone+Serial+Port+Tutorial which says you FIRST have to send * as a handshaking message and wait for a response(from iphone embedded soft i assume??) and then the Tx/Rx should be ready – ppumkin Jul 18 '12 at 11:21
  • well the handshaking * is news to me. i wonder if that is necessary if i am only trying to receive serial data. – ipatch Jul 18 '12 at 18:40
  • 2
    Well I tried a couple of things and still no luck. I created a google doc that I will try and keep updated with my progress, it can be found here -> docs.google.com/document/d/… – ipatch Jul 20 '12 at 1:33
up vote 3 down vote accepted

I got TTL serial receive on the iPhone working yesterday. Instead of you using minicom to check the serial connection I issued the following command: cat /dev/tty.iap 9600 This displayed the output my Arduino was sending on the serial TX line. I also soldered a new dock connector (>.>) I used the pod breakout.

enter image description here

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.