3
\$\begingroup\$

Recently at Embedded World 2018 in Nuremberg I got, for free, NUCLEO-L433RC-P with STM32L433RCT6P chip onboard. I want to broaden my knowledge in STM32 chips. Before, I did simple stuf on STM32F4.

NUCLEO-L433RC-P

All the jumpers on the board are placed correctly.

I opened STMcubeMX, selected the NUCLEO-L433RC-P board from board selection and used all the default settings for it. I also did a version with selecting the STM32L433RCTxP chip directly, not the board, and setting everything manualy. My end goal was to blink a LED.

I folowed this tutorial only for guidance, did not change RCC or SYS or anything like that: https://www.youtube.com/watch?v=BJdXR0Al6os

This is where problems began. After generating code and opening Keil I got the update window and updated everything for STM32L433RCT6P. Under boards there was no NUCLEO-L433RC-P to be found or updated. After closing that window this appeared (I tried and tried again while going through all the options):

options 1

At this point I just tried writing code an seeing what would happen. I have checked everithing in options for targer and compiled everything. After clicking the Download button if got the same thing for both scenarios:

enter image description here

What am I to do to fix this?

Versions: Keil V5.24.2.0, STM32CubeMX 4.24.0

\$\endgroup\$
2
\$\begingroup\$

Device not found in available Device Family Packs. Use PackInstaller: 'Check For Updates' to update the list of supported devices.

Keil doesn't know the device. Since Keil 5, it doesn't by default come with all supported devices. You have to install devices manually via the Pack Installer.

enter image description here

In the log:

No Algorithm found for: 08000000H - 08000F53H.

Since Keil does not know the device, it has no idea how it should even begin to program it. It needs firmware to load in SRAM and run to be able to program flash. This comes with the pack installer.

enter image description here

Error: Flash Download failed - "Cortex-M4"

That's just the least descriptive error message you get on almost every error.
Get used to it.

\$\endgroup\$
  • \$\begingroup\$ Thank you for you answer! I already had the lastest version installed. How I got it to work was by downloading previous versions in packinstaller. After I downloaded older vesions my pc crashed... but I still thank you a lot, you LED me to the right answer...Magic :D \$\endgroup\$ – Lazyboy Mar 10 '18 at 14:28
  • 1
    \$\begingroup\$ @Lazyboy Good! If the question was answered, please mark it answered. \$\endgroup\$ – Jeroen3 Mar 10 '18 at 21:11
  • \$\begingroup\$ @Lazyboy: I have the same issue with the same board, but even after installing older package versions, the issue still persists. Did you do anything else? \$\endgroup\$ – RunoTheDog Jul 15 '18 at 12:13
  • \$\begingroup\$ Disrigard that comment, that wasnt the answer, as I found later, I am sorry I didnt write down the real answer later. I will try to think of it today and reply here \$\endgroup\$ – Lazyboy Jul 15 '18 at 12:16
  • \$\begingroup\$ Ok, just solved it - you have to also check, that the appropriate device is selected in the 'Device' tab under "Options for target" (besides setting the debugger and programming algorithm). \$\endgroup\$ – RunoTheDog Jul 15 '18 at 12:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.