0
\$\begingroup\$

I recently bought a 3G SIM5320A Shield Click here.I'm facing some problems while communicating with the module using a USB to serial converter.The module doesn't seem to respond to the AT commands. I tried different settings for the COM port such as changing the baud rate but still no luck.Any suggestions on what might be wrong. Note: I'm powering the module from the USB to serial converter.

I tried Arduino mega to send AT commands by uploading an example sketch from the adafruit_fona library still doesn't work.FONA basic test Initializing....(May take 3 seconds) Attempting to open comm with ATs ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- ---> AT <--- Timeout: No response to AT... last ditch attempt. ---> AT <--- ---> AT <--- ---> AT <--- ---> ATE0 <--- ---> ATE0 <--- Couldn't find FONA

I got this working the issue seems to be the supply has to be above 9volts.Now the module is easily drawing 178mA standby.

\$\endgroup\$
  • 1
    \$\begingroup\$ "Note: I'm powering the module from the USB to serial converter." Don't do that. GSM modules are notorious for very high pulse current demands. They really run best on the batteries most were designed for (typically in actuality being the guts of outdated "feature" phones) \$\endgroup\$ – Chris Stratton Mar 15 '18 at 20:12
  • \$\begingroup\$ @ChrisStratton I tried powering the board using my lab power supply the module seems to draw around 130-150mA.There's also a green led on the board which according to the manufacturer would light up when the supply is OK. \$\endgroup\$ – V.Singh Mar 15 '18 at 20:21
  • \$\begingroup\$ @V.Singh (a) Please edit your question & add clear, in-focus photos of your hardware, showing all power wiring. (b) "I tried powering the board using my lab power supply [...]" You must also add a list of all your attempts to solve your problem & testing so far (like using that different PSU) and their results, to avoid us wasting time making the same suggestions. (c) List all test equipment available to you (e.g. oscilloscope, DMM etc.) & your experience using them. (d) "a green led on the board which [...] would light up when the supply is OK." That's false (I checked the schematic). \$\endgroup\$ – SamGibson Mar 15 '18 at 21:13
  • \$\begingroup\$ @samGibson the supply was set to 5volts I was going according to the IC manufacturer but the board seems to require around 9 Volts to work properly.The module is working now \$\endgroup\$ – V.Singh Mar 15 '18 at 21:16
0
\$\begingroup\$

Try using coolterm terminal with the following configurations, Baud-rate 115200(check what is the default baud rate) , In terminal key emulation ,select CR+LF. In the terminal options,select line mode,now you can type 'AT' in the new box that appears below the coolterm window. Have a check on the following things as well.

  1. Make sure you are pressing the POWER_ON button for at least 4 sec, and find if the network indication led is blinking.
  2. As per the link you have given, the shield uses an adapter,hence use the rated adapter.

Also check the port you must be connecting to and jumper configurations(if any).

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.