2
\$\begingroup\$

I want to cut some cheap mylar stencils from mylar for quickly assembling some fine pitch SMT designs. I have access to a laser cutter for this purpose. The laser cutter accepts various file types... unfortunately g-code or RS274x is not one of them. Does anybody have any options for converting output from Altium to a DXF?

Even better, with an option to offset the lines by half the kerf of the laser? Though I can always do this manually using a CAD program...

EDIT:

For extra credit :), a solution to go straight from RS274x to DXF (free) would be desirable as well. Sometimes I let the board house panelize and all I get back is the gerbers.

\$\endgroup\$
3
\$\begingroup\$

When editing a layout in Altium, you can do "File->Save As", and then for the file type choose "Export AutoCAD files".

This enables saving as either DXF or DWG and gives a few other options as well:

enter image description here

\$\endgroup\$
  • \$\begingroup\$ That's great! I was looking for an 'export' option. I didn't expect to see it under 'save as'. I was able to export and hide all layers but top paste. From there I exploded the mess and got what I was after! I suppose if I exported as primitives I wouldn't have to explode. \$\endgroup\$ – Jason Jul 24 '12 at 18:44
  • \$\begingroup\$ 1. Putting file format exports under "Save As" seems to be the new black for Windows applications. I'm pretty sure Office, etc., do it this way in recent versions. 2. Notice the option to save only "currently visible layers" in the dialog I included in my answer---might make it somewhat less tedious to create files with just one layer represented. \$\endgroup\$ – The Photon Jul 24 '12 at 19:17
  • \$\begingroup\$ I did try the 'Currently Visible Layers' option and it didn't work as I expected. I selected my top mask and used shift + s to hide all layers except the current. I then exported. Unfortunately the export contained all layers. This wasn't a big deal though as it's a simple matter to turn off the other layers... just a few seconds of time. \$\endgroup\$ – Jason Jul 24 '12 at 19:26
  • \$\begingroup\$ In my version of Altium, Shift+s doesn't hide layers, it just dims them. If I go to the Layers dialog and actually hide the other layers, the DXF export seems to work nearly as expected. The output DXF has 2 layers, A "0" layer that doesn't seem to contain any information, and another layer with the info from the layer I left visible before exporting from Altium. I'm using Altium 10.391.something. \$\endgroup\$ – The Photon Jul 24 '12 at 20:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.