1
\$\begingroup\$

I have a small OLED display that I'd like to drive with an ATtiny85 micro controller. The OLED is the 4 wire SPI type, with no CS. It has a Reset pin that is required to be pulsed low-high at power on and then kept high for normal operation.

This seems like a waste of a pin - I want to be able to do other things with the MC.

schematic

simulate this circuit – Schematic created using CircuitLab

Is there a way I can generate the required pulse without using a MC pin?

Power On sequence, as stated in the data sheet:

enter image description here

with RES# being the one I want to avoid using a pin for.

Thanks

\$\endgroup\$
  • \$\begingroup\$ You'd need to post a schematic of your layout and thinking. There's a schematic button on the editor toolbar. \$\endgroup\$ – Transistor Apr 7 '18 at 21:18
  • \$\begingroup\$ Can you manipulate MOSI output state or transition to trigger a 1 shot to replace SS enable for desired interval? \$\endgroup\$ – Tony Stewart Sunnyskyguy EE75 Apr 7 '18 at 21:55
  • \$\begingroup\$ Welcome to the site. Please can you edit your question to show a schematic (not a block diagram or wiring diagram). The schematic editor here is a breeze to use. The better the quality of question, the better the quality of the answers you will attract. Again, a warm welcome to the site. \$\endgroup\$ – TonyM Apr 7 '18 at 21:56
  • \$\begingroup\$ I don't think I can use MOSI because I'll need that to transmit display information later and if RES# is pulsed again it'll re-reset the display controller. \$\endgroup\$ – MalphasWats Apr 8 '18 at 0:12
1
\$\begingroup\$

Yes, You don't need connect this pin to MCU. there are some possibilities to save one pin on MCU:

  1. connect directly RES# pin to VDD (although this is not recommended, I see this in some applications and it is working)
  2. try find existing reset signal with right polarity on your board (external reset of AT tiny)
  3. add RC with diode which make short pulse after power-up, like:
    • 100nF between RES# and GND
    • 10kOhm between RES# and VDD
    • one diode from RES# to VDD
\$\endgroup\$
  • \$\begingroup\$ I have tried connecting RES# and Vcc, however, this doesn't work, the screen sometimes displays garbage and sometimes just stays blank. If I connect RES# to Reset on the ATtiny it works perfectly if I ground Reset momentarily, however, it doesn't work properly on first power up (power up then reset works ok, but is sub-optimal). I will try option 3 when I get a chance! \$\endgroup\$ – MalphasWats Apr 8 '18 at 13:40
  • \$\begingroup\$ Option 3 does indeed appear to work for first power on, however, it produced the same behaviour if connected to Reset on the ATtiny - it displays garbage on power on but works after a reset pulse to both. A diode between RES# and Reset appears to have done the trick! Thank you. \$\endgroup\$ – MalphasWats Apr 8 '18 at 13:59
  • \$\begingroup\$ It is normal if display garbage, it is random data in display SRAM. You need first erase screen and then send command to power ON display. \$\endgroup\$ – vlk Apr 8 '18 at 14:01
  • \$\begingroup\$ In option 3, if sometimes after power-up the display will be not restarted correctly, maybe you will need bigger capacitor, try 1uF. in some schematics is used also 10uF, but then don't remember to wait longer before first communication with display. \$\endgroup\$ – vlk Apr 8 '18 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.