0
\$\begingroup\$

schematic Using the falstad.com circut designer I found a simple mosfet switching circut. However, upon constructing it in real life I found that:

~after powering it on the led starts glowing dimly (it should not glow at all)

~after pushing the button the led brightens up and stay on until the power is cut out (it would be funny, if they st me a triac instead of an mosfet!)

What am I doing wrong here and how can I fix it? Do you have any working mosfet switch circuts?

Thanks in advance!

\$\endgroup\$
  • 2
    \$\begingroup\$ You're not providing any path to discharge the gate when the switch is open. Try adding a 10k pulldown resistor. \$\endgroup\$ – Dave Tweed Apr 26 '18 at 21:37
  • 1
    \$\begingroup\$ To add to what @DaveTweed said .....you absolutely need a pulldown for the gate, and you need to move the LED to the Drain side of the FET. \$\endgroup\$ – Jack Creasey Apr 26 '18 at 21:43
6
\$\begingroup\$

schematic

simulate this circuit – Schematic created using CircuitLab

Try the above. Your circuit has two problems, first it is not giving the MOSFET the full 6V on the gate (relative to source), rather it is reduced by the LED forward drop. That is solved by putting the LED in the drain circuit.

Second is that there is no way to discharge the gate charge on the MOSFET so it will tend to retain the previous on or off state for some time when the switch is open, until leakage causes it to go towards 'on' or 'off'.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.