0
\$\begingroup\$

I have this AC 20V to DC 5V converter with zener diode circuit. It works as expected if there is no load connected. As soon as I connect the load, in this case LED diode with 20mA consumption, the 5V output is reduced to 1.9V only and LED lights only with low light. I tried to calculate various R1 values from 120Ohm to 3K, but i never can reach output voltage higher then 2.2V. I also tried to reduce and even remove R2, but there was no significant change. Without load output gives 5.1V. Zener current is calculated for 20mA without load.

Can someone point me what can be the problem?

20V AC source is 10Amps strong source, so it can be excluded as source of the problem.

enter image description here

enter image description here

enter image description here

\$\endgroup\$
7
  • 1
    \$\begingroup\$ The first problem is that the LED is backwards. Welcome to EE.SE. \$\endgroup\$
    – Transistor
    Apr 27, 2018 at 21:46
  • \$\begingroup\$ thanks, ok, this is only in diagram, in reality it is connected correctly .. fixed \$\endgroup\$
    – B.Ondrej
    Apr 27, 2018 at 21:48
  • \$\begingroup\$ Look up the emitter-follower supplement to the zener diode reference. Replace D2 with a BJT, in effect: BJT with Zener diode. \$\endgroup\$
    – jonk
    Apr 27, 2018 at 21:53
  • \$\begingroup\$ That's better. Can you post a photo of your setup? Is there any chance that you have the LED directly across C1? \$\endgroup\$
    – Transistor
    Apr 27, 2018 at 21:57
  • 1
    \$\begingroup\$ The current is limited by R1 and flows for only half a cycle to C1 through D2. You didn't say if the 20 V AC was RMS or peak. I'll assume RMS for now. So probably on the order of 5-6 mA RMS through R1 because it's only half-cycle. Probably about half that will wind up in the LED itself. \$\endgroup\$
    – jonk
    Apr 27, 2018 at 22:41

2 Answers 2

2
\$\begingroup\$

schematic

simulate this circuit – Schematic created using CircuitLab

Figure 1. Various options.

  • (a) Your circuit. Note that C1 charges up on positive half-cycles but the LED discharges it continuously. You need to take this into account in your calculations. R1 is conducting on negative half-cycles with current through D1 so that's a waste of energy.
  • (b) Moving the diode to the left solves the negative half-cycle problem and cuts power consumption in half. It doesn't solve the LED problem and the voltage on C1 will droop on negative half-cycles.
  • (c) solves the droop by providing a high-voltage DC supply that is regulated by the Zener. We still haven't worked out the R values though.
  • (d) It's not clear why you don't just use this arrangement. Maybe you need to avoid flicker.

Assuming your 20 V supply is 20 V RMS then the peak voltage should be about 30 V. Working with the RMS value and assuming you want 20 mA through the LED we can work out the following:

$$ I_{R1} = \frac {20-5.6}{2k} = 7.2 \ \mathrm{mA} $$

Already we don't have enough current for the positive half-cycles. Having no useful current for the negative cycles makes the situation worse.

Rethink your circuit and the requirements. Then do the design. Update your question if required.

\$\endgroup\$
5
  • \$\begingroup\$ Part #1. Thank you very much for comprehensive explanations and help. Really appreciate. So I understand the point with half cycle and based on that I redone the circuit based on c) variant from Transistor - the post above. Only difference is I use 1N4002 D11. I calculated R6 value to 1K and R7 for 330Ohm. I am sorry to say, that the circuit produces again the same problem as my first setup #1. \$\endgroup\$
    – B.Ondrej
    Apr 28, 2018 at 15:04
  • \$\begingroup\$ OK. The 1N4148 is the default in CircuitLab. I forgot to change it. Q1. What's the voltage reading on C3 in my Figure 1c? Q2. Why do you think you need the Zener? Why not use (d)? \$\endgroup\$
    – Transistor
    Apr 28, 2018 at 15:07
  • \$\begingroup\$ Part #2. So voltage also drops to 1.7V when LED is connected. Otherwise it outputs 5.6 V with no load. 2nd I also created another setup with 4 diodes bridge and connected that same way as variant c). Also solution with this bridge drops voltage to approx 1.8V when LED is connected. I tried various LED diodes. \$\endgroup\$
    – B.Ondrej
    Apr 28, 2018 at 15:08
  • \$\begingroup\$ You didn't answer either of my questions. \$\endgroup\$
    – Transistor
    Apr 28, 2018 at 15:09
  • \$\begingroup\$ Q1 answer: On input 20V AC, on C3 24V DC, on Zener pin 5,6V, on output 5,6V DC. On output with LED connected 1.54V DC \$\endgroup\$
    – B.Ondrej
    Apr 30, 2018 at 19:28
0
\$\begingroup\$

EDIT: It looks the problem is resolved now. I basically used solution "C", but rethinking it little bit, i decided to try to use Zener 3.3V instead of 5.6V. R6 calculated value is now 1K8, at 0.6W. I have now around 2V on LED with current over LED ~18mA. R6 stays cold, which is what I was looking for. thanks everyone for help.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.