1
\$\begingroup\$

When I set the horizontal axis to something large (40ms/div or greater) and hit the Single button, the scope triggers immediately, although no trigger event has occurred. I tried the following:

  • Setting the trigger to something ridiculously high and grounding the channel that it triggers on, to make sure that noise was not triggering it. It still triggered immediately.
  • Setting the horizontal scale to 20ms/div, hitting the Single button, and then increasing to 40ms/div. This worked; i.e. did not trigger until the trigger event actually occurred.

I am using a Tektronix MSO54, but I also recall observing this phenomenon on another scope in the past. This has got to be something obvious, but for the life of me I can't figure out what.

\$\endgroup\$
2
  • \$\begingroup\$ Is this SPI bus triggering, SS active, or Flexray? Or just run-of-the-mill analog edge triggering? \$\endgroup\$ Commented May 3, 2018 at 1:38
  • \$\begingroup\$ Run of the mill. Falling edge. \$\endgroup\$
    – Annie
    Commented May 3, 2018 at 2:37

2 Answers 2

1
\$\begingroup\$

Make sure your trigger mode is set to edge, and not auto.

From Tek: Understanding Vertical and Horizontal Settings

Another basic trigger control you should understand is the default or AUTO trigger mode. In AUTO, the scope waits for a trigger and if it doesn’t see one, it captures and displays a waveform even if trigger conditions aren’t being met.

Otherwise it sounds to me like a firmware bug issue.

I would recommend checking your firmware version, and updating the the latest version, 1.6.3, which was updated as recently as Feb 15, 2018.

The revision notes contain a bunch of items that could be potentially responsible.

\$\endgroup\$
3
  • \$\begingroup\$ Trigger type is set to edge. The trigger mode was set to "Normal," I thought, but when I checked again it was set to "Auto." It doesn't make sense because at lower horizontal scales it was not triggering. If it was truly in Auto mode the time scale shouldn't matter. \$\endgroup\$
    – Annie
    Commented May 3, 2018 at 16:12
  • 1
    \$\begingroup\$ However, after setting horizontal mode to "Manual" and then setting trigger mode to "Normal", the problem is now gone. I returned the settings to the way they were previously, and the problem is still gone...so I am inclined to think you are correct and there is a firmware issue. I am using the most recent firmware. If this problem recurs I will contact Tektronix and update here with their answer. In the meantime I am accepting your answer because "Auto" vs "Normal" was indeed the problem. \$\endgroup\$
    – Annie
    Commented May 3, 2018 at 16:21
  • \$\begingroup\$ @Annie Right, if it occurs again I would definitely report it. These bugs are more common than one might think. I found a bug in my Keysight DSO204a oscilloscope last month and reported it. I found that it would miss one out of every 10 million samples (or so). They didn’t believe me at first but they finally conceded and were able to reproduce it. Other than that it is actually a great scope (keysight.com/en/pdx-x202067-pn-DSOS204A/…). \$\endgroup\$ Commented May 5, 2018 at 16:40
1
\$\begingroup\$

Set horizontal mode to manual. page 52

\$\endgroup\$
1
  • \$\begingroup\$ This does not seem to be the root of the problem but may be part of it; see my responses to Blair Fonville. \$\endgroup\$
    – Annie
    Commented May 3, 2018 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.