1
\$\begingroup\$

I've created a dual source energy harvesting board to store energy from small energy sources, like a 3V 15mA solar panel, into a 3F 2.7V supercap and to power a small wireless node (3.3V, 30mA), but I am having trouble finding the cause of a current leak. Schematic is below: enter image description here

The voltage regulator LTC3125 (U1) gets the energy from the solar panel and steps the voltage up to 2.65V to charge the 3F 2.7V supercap.

The supercap is the input for the 3.3V voltage stepup regulator LTC3525D-3.3 (U3) and its output (3.3V) goes to the load (wireless node).

This regulator get shut down when the voltage of the supercap goes below 0.9V and starts if the supercap goes above 2.5V. This is done by the non-inverting op-amp with additional hystheresis, the MAX9015 (U2), that drives the shutdown pin of the LTC3525.

The op-amp is powered by two sources: if the sun shines, it is powered by the 2.1V regulated voltage from the LTC3105 (LDO, pin2). If no sun and supercap >0.9V, the power comes from the LTC3525D-3.3 output . If no sun and supercap <=0.9, then the opamp is off and so is the LTC3525. Usually the supercap is >0.9V. Min VCC of op-amp is 1.8V.

There is also a connection from supercap to VCC of the op-amp through diode D9, but I did this only to stay inside the "input command mode voltage range" of the op-amp (VCC+0.2V). Without this, I had a current leak, when the sun was not shining because of op-amp latchup.

Everything works fine except for a current leak that happens when:

  • 1.24V < V_Supercap < 2.5V

  • Solar input voltage < (V_Supercap + (0.2V or more))

  • LTC3525 not started (no 3.3V output)

In this situation, the supercap discharges circa (44uA-60uA) instead of charging (0.01mA or more).

If I disconnect the solar panel, there is no current leak. If its voltage is similar or higher than supercap voltage, the supercap charges.

I suspect the cause is something in the op-amp, as its internal V_REF = 1.24V and I use this directly connected to the IN- of the op-amp. The V_REF output impedance is 35kOhm, and the current leaks is exactly V_Supercap / 35kOhm. The IN- and V_Ref are at 1.24V as soon as the supercap >= 1.24V.

What could be the cause of this and how can I solve it? Or maybe is the problem somewhere else?

Thank you very much for your help.

U1 (LTC3105)

  AUX  =  1.49V   
  V_OUT = 1.49V  
  SW    = 1.07V   
  V_IN  = 1.07V   
  FB    = 0.53V
  LDO   = 1.49V   
  MPPC  = 1.39V

U2 (MAX9015)

  REF=IN- = 1.23V
  IN+     = 0.72V
  VCC     = 1.44V
  OUT     = 0V 

U3 (LTC3525)

  SHDN    = 0V
  V_IN    = 1.49V
  SW      = 1.49V
  V_OUT   = 0V

PSU (to simulate solar cell):

 1.10V 30mA 

PSU current draw = 0mA.

Supercap:

 1.49V discharging at 44uA
 If I turn PSU off, supercap discharges with 12uA.
\$\endgroup\$
  • \$\begingroup\$ Is the cap meeting it’s leakage spec? \$\endgroup\$ – Sunnyskyguy EE75 May 6 '18 at 21:28
  • 1
    \$\begingroup\$ No, the supercap max leakage current is one order of magnitude lower. \$\endgroup\$ – haku15 May 6 '18 at 22:47
  • \$\begingroup\$ Did you just trust the datasheet or verify it? \$\endgroup\$ – Sunnyskyguy EE75 May 6 '18 at 23:00
  • 1
    \$\begingroup\$ It would be useful to list all the pin voltages. If you aren't getting 3V at U1-5 reduce R2 by a factor of 10 to get 0.3V \$\endgroup\$ – Sunnyskyguy EE75 May 6 '18 at 23:16
  • 1
    \$\begingroup\$ Thanks Tony for help. Supercap current leak can be trusted: I could see 7uA on an older revision of this circuit, and that includes other ICs. Here voltages: U1 (LTC3105) AUX=1.49V, V_OUT = 1.49V, SW = 1.07V, V_IN = 1.07, FB = 0.53V, LDO = 1.49V, MPPC = 1.39V, ; U2 (MAX9015) REF and IN- = 1.23, IN+ = 0.72V, VCC= 1.44V, OUT = 0V, ; U3 (LTC3525) SHDN = 0V, V_IN = 1.49V, SW = 1.49V, V_OUT = 0V, ; Current drawn from PSU = 0mA. If I turn PSU off, supercap discharges with 12uA. R2 should be fine, I don't get why I should change it: solar panel is 3V. \$\endgroup\$ – haku15 May 7 '18 at 16:26
0
\$\begingroup\$

U1 (LTC3105)

. FB    = 0.53V      AUX  =  1.49V   
  LDO   = 1.49V      V_OUT = 1.49V  
  FBLDO =    0V      PGOOD = open
  SHDN* = open       SW    = 1.07V   
  MPPC  = 1.39V      V_IN  = 1.07V 

If PSU off , V_IN on U3 is open and C4=3F/2.7V
- V_OUT/(R4+R5//R6)=1.49/(300k+560k//620k)=2.48uA
- V_OUT/(R1+R2)=1.49/(1M+1.65M) = 0.56uA
- above = 3uA total
- supercap discharges with 12uA.
- D9 leakage = ? with Vf= 1.49-1.44=0.05V

  • REMOVE D9 to isolate then remove any other paths for causes of leakage

U2 (MAX9015)

. REF   = 1.23V      n.c.
  IN-   = 1.23V      Vcc   = 1.44V  
  IN+   = 0.72V      OUT   = 0V 
  Vee   =    0V      n.c.

U3 (LTC3525)

  SHDN    = 0V       SW    = 1.49V
  GND     = 0V       GND   = 0V  
  V_IN    = 1.49V    V_OUT = 0V

PSU (to simulate solar cell):

 1.10V 30mA Supercap: 
 1.49V discharging at 44uA
\$\endgroup\$
  • \$\begingroup\$ Tony, I am so gratefule for your great help. I had to add D9, so that IN+ < VCC+0.2 (input common mode voltage range of op-amp), otherwise op-amp latches and 2.3mA current leak. If I replace D9 with a wire, a loop happens, where LTC3105LDO (2.2V) and LTC3525 V_OUT 3.3V feed back into the supercap. \$\endgroup\$ – haku15 May 7 '18 at 17:40
  • \$\begingroup\$ It should NOT take very long to find the cause of leakage, start removing parts, then the fix may be self evident. \$\endgroup\$ – Sunnyskyguy EE75 May 7 '18 at 17:47
  • \$\begingroup\$ I've tried on 75K on R2 to have MPPC @ 0.75V, instead of 300K and 3V as before. The current leak remains, but I've noticed, it starts when the PSU voltage < set MPPC. So I've disabled MPPC (0 Ohm R2) and I have no more current leak, but no matter what voltage I set on the PSU, the PSU shows a load of max 0.6V and supercap charges with 30uA. Only if I stepup the current a lot, the voltage goes up a bit. Very strange. I've tried an older board revision, and similar result, so the LTC3105 is not defective. No idea... \$\endgroup\$ – haku15 May 13 '18 at 16:48
  • \$\begingroup\$ Is your L switching ? Sounds like it’s not conducting 40KHz to 1MHz \$\endgroup\$ – Sunnyskyguy EE75 May 14 '18 at 23:01
  • \$\begingroup\$ I don't know how to test that. I don't have an oscilloscope. \$\endgroup\$ – haku15 May 16 '18 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.