0
\$\begingroup\$

we have disconnected the ST-link from the nucleoboard and prepared it correctly for its use. we connected it back to the nucleoboard, and everything worked like it should. We want to use this ST-link to make contact to the MCU of a flight controller that we have designed. the connection goes as follows:

ST-link: 1. VDD 2. SWCLK 3. GND 4. SWDIO 5. NRST 6. SWO

Flight controller: 1. GND 2. SWCLK 3. SWDIO 4. SWO 5. NRST 6. VDD

NRST goes to NRST, SWO to SWO etc.

When we connect the ST-link to STM32CubeProgrammer, the ST-link appears as a usb unit and we get contact with the program. we get an error though: ST-LINK Firmware version : V2J29M18 Error: ST-LINK error (DEV_TARGET_CMD_ERR)

Does anyone have an idea whats wrong?

\$\endgroup\$
  • \$\begingroup\$ Which Nucleo board? As I recall they are programmed for the specific processor on the Nucleo board and are not full ST-Link2 images. \$\endgroup\$ – Dean Franks May 8 '18 at 11:05
  • \$\begingroup\$ The nucleoboard is: Nucleo-F767ZI \$\endgroup\$ – Ole Halvor May 8 '18 at 11:07
  • \$\begingroup\$ Have you tried using the ST-Link Utility? Maybe it needs a firmware update, the latest for my is V2.J29.S7 - which seems higher than yours. \$\endgroup\$ – Arsenal May 8 '18 at 12:13
  • \$\begingroup\$ What is the STM32CubeProgrammer? I have never heart of it. \$\endgroup\$ – P__J__ May 8 '18 at 15:48
  • \$\begingroup\$ Comments are not for extended discussion; this conversation has been moved to chat. \$\endgroup\$ – clabacchio May 9 '18 at 7:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.