0
\$\begingroup\$

I have a MOSFET IRF Z44n and want to control 5V using 3.3V at the gate:

If I replace L1 with a voltmeter, the circuit behaves as expected: if SW1 is closed, I measure 5V. If SW1 is open, I measure 0V. I also can connect a lamp in place of L1, and it switches on when SW1 is closed (the lamp pulls less than 10mA).

Now the problem: if I close SW1 and connect the coil L1 that pulls normally about 500mA, I measure 0V in parallel to L1 with a total current of <10mA. Normally, the coil should pull its 500mA and generate a significant magnetic field (which it doesn't). As described above, connecting a lamp works.

Is the problem that the coil is pulling to much current? It isn't above the max current described in the data sheet. I really don't know what to do.

schematic

simulate this circuit – Schematic created using CircuitLab

\$\endgroup\$
  • 2
    \$\begingroup\$ Have a look at Fig.3 on pg.3 of the datasheet. You'll notice that they don't even bother to extend the graph below Vgs 4.5V - you're only giving it 3.3V... The specs table on pg.2 lists VGS(th) as 2V(min) to 4V(max), so there's really not any guarantee that the MOSFET will even begin to turn on with 3.3V. \$\endgroup\$ – brhans May 15 '18 at 18:08
  • 1
    \$\begingroup\$ The 2-4V Vgs(th) spec says that for less than 2V it's guaranteed to be off and for greater than 4V it's guaranteed to just barely start turning on - that's the threshold. Anything in between is unpredictable. If you want it to turn on 'properly' don't even think of Vgs any less than 5V. \$\endgroup\$ – brhans May 15 '18 at 18:13
  • 1
    \$\begingroup\$ There are other issues also. You need to add a pull down resistor to the gate so that the gate can discharge when the switch is opened. This is probably just a notation issue, but your voltage source (V2) has the load and FET connected to the "wrong" pole. \$\endgroup\$ – pgvoorhees May 15 '18 at 18:22
  • 1
    \$\begingroup\$ @black 10k would be fine. But any middle-value resistor (10's of k) would be alright. It's not a critically valued component (unless it is, but you'd know). \$\endgroup\$ – pgvoorhees May 15 '18 at 19:39
  • 2
    \$\begingroup\$ Your schematic is incorrect. Show how V2 is connected. \$\endgroup\$ – winny May 17 '18 at 13:39
2
\$\begingroup\$

MOSFET is limiting current, not the coil, so it won't 'pull' more current than the MOSFET is allowing to flow.

Agree with others that you have not fully turned it on @ 3.3V. Other transistors of the same type MAY turn on fully at 3.3V, but this one does not.

\$\endgroup\$
0
\$\begingroup\$

Power Mosfets of this type are usually available in two flavors:

Vgs-th @ 25C between 2 and 4 V and Rdson specified at Vgs=10V
Vgs-th @ 25C between 1 and 2/2.5 V and Rdson specified at Vgs=5V

The suggested gate voltage for good Rdson performance is 10V for the first and 5V for the second.
Your chosen device belongs to the first flavor (also called standard gate). At 3.3 V is basically off, and it will start to show decent performance around ~ 7 V.

You should use a Mosfet of the second flavor (called logic level) and use the 3.3V to drive a bipolar to connect your 5V supply to the Mosfet gate.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.