I quite like Qucs now that I more or less have the hang of it. Unfortunately, I can't figure out how to get a parametric sweep working.

I'm running an AC simulation on this circuit:


For now I'm not asking on how to improve or fix this circuit; solely on how to fix parametric sweep simulation.

The output of the simulation is shown in this table:

simulation table

The gain is not being affected by the inductor sweep when it most certainly should be. How do I fix the sweep?

  • 1
    \$\begingroup\$ You need to set the inductance of one of your inductors to have the value Lant. (And probably make a variable definition so the model will still be valid when you aren't running the sweep) \$\endgroup\$ – The Photon Jun 5 '18 at 18:20
  • \$\begingroup\$ Meaning, you have an inductor with designator Lant, but its inductance is 10.042 uH. You probably should change its inductance to be Lant instead. \$\endgroup\$ – The Photon Jun 5 '18 at 18:21
  • \$\begingroup\$ Caveat: I don't use Qucs, but I do use ADS, which is the commercial tool that Qucs seems to be trying to copy. \$\endgroup\$ – The Photon Jun 5 '18 at 18:22
  • \$\begingroup\$ @ThePhoton OK. I'm unable to see where I make a variable definition? \$\endgroup\$ – Reinderien Jun 5 '18 at 18:22
  • \$\begingroup\$ In ADS, there's a "variable definition" object you add to the schematic, similar to the equation object in your design where you define G. \$\endgroup\$ – The Photon Jun 5 '18 at 18:23

As @ThePhoton indicated, the proper way to use a parametric variable is to write a variable name in the Parameter Sweep param and to write the same variable name instead of a constant value in the component field that you want to sweep; i.e.:



| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.