0
\$\begingroup\$

I have a 2 layer PCB with GND planes on both sides. I have a ZigBee RF module that is placed on top of the PCB. I made sure there was no ground plane on both sides of the PCB that interfered with the module's PCB antenna. I also have GND stitching vias around the edge of the board as well as throughout the inside of the PCB (not sure what calculations to do to find out via stitch spacing + hole sizes). I mainly did the via stitching because I learned that if I have a ground plane on top and bottom that for all intents and purposes they can be seen as a single continuous ground plane.

I uploaded an RF test program into the module through the debug port to see if it'd work. The LED would light up to indicate if the program was working. However, I found out that the program wouldn't start unless I pushed the module down onto the PCB - or rather simply placed my fingers around the module or debug port. Then it worked. I double checked my solder joints - even redid them to be sure, but that wasn't the problem. So I'm not sure what is causing this strange issue.

enter image description here

P1.0, P1.1, P0.7 are used to control the CC2592. I don't use any other pins.

So my questions are:

  1. What may be wrong with my PCB design, and how can I get it to work without my hand interactions?

    • Via stitchings?
    • "No GND" area around module's PCB antenna?
    • GND planes?
    • Traces?
    • etc.
  2. After resolving the 1st question, how might I optimize my PCB for the maximum performance of the RF ZigBee module (TX and RX)?

--- UPDATE ---

I chose to use this module because it is cheap and it has proven reliable in my tests mentioned below.

This module is CC2530 (ZigBee) + CC2592 (Range Extender) module. The full title of this module is "CC2530F256+CC2592 Wireless Module 2.4G with PA|zigbee PCB Antenna | Ultra nRF24L01P".

Tests I've done I use the Z-Stack program to configure this device as a Home Automation Light which can be controlled by a coordinator. I had tested this on a breadboard and perf board, and there was no problem. I had an old PCB design, and this worked fine as well.

\$\endgroup\$
  • \$\begingroup\$ First thing you should do is make sure all the required connections actually exist in your schematic - oversights leaving something floating would cause the type of behavior you see. Then make sure the solder joints on the board are actual joints. \$\endgroup\$ – Chris Stratton Jun 7 '18 at 2:44
  • \$\begingroup\$ I checked that all used pins were connected to their correct components. I also checked that my solder joints were good. \$\endgroup\$ – Alex Feng Jun 7 '18 at 2:46
  • \$\begingroup\$ Do you have a link to the module that you are using? \$\endgroup\$ – crj11 Jun 7 '18 at 2:50
  • 1
    \$\begingroup\$ You have no thermal relief on the ground pad at pin 1, in fact you have no "pad" there at all but have let it just become merged with the ground plane; really check under high magnification from the side that it is actually soldered as you may very well be surprised. More generally, you are not providing enough factual information about the component or circuit to have an answerable question. \$\endgroup\$ – Chris Stratton Jun 7 '18 at 4:36
  • 1
    \$\begingroup\$ That link to the aliexpress site is just sad. Metric crap load of pictures, and one fuzzy schematic - and no datasheet. \$\endgroup\$ – JRE Jun 7 '18 at 19:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.