6
\$\begingroup\$

I am designing a low noise SMPS like this http://www.ti.com/lit/df/tidrgc2/tidrgc2.pdf switching from 40-90 kHz.

I have a weird problem, on the output we are seeing a spike of noise at 5.5 kHz and multiple (decaying in a few multiples), tested with differential amplifier and correct techniques.

We have no idea where it comes from (maybe ringing of secondary transformer inductance + caps)?

Noise capture

Update:

We added a C and R across transformer, 1000 uF and 20 ohm and we seen a 6 dB reduction on noise. We are experimenting with different values to lower the noise. The only LC tank we are seeing is diode capacitance (and the RC snubber across it) and transformer secondary winding.

Second update.

We used 2x47uF parallel across pin 6/10 + 50R and spike is slightly lower .

\$\endgroup\$
  • \$\begingroup\$ Comments are not for extended discussion; this conversation has been moved to chat. When you're done, edit any relevant new information into the question. \$\endgroup\$ – Dave Tweed Jun 8 '18 at 12:09
3
\$\begingroup\$

Good question. People think that the only noise that can occur is the switching frequency and harmonics. This is not true. You are not the only one that has found noise below the switching frequency. Normal SM PS filter LC parts will work well at say 40 kHz but your 5.5 kHz will cut through it like butter. It will be better to nail this at the source than use a large expensive output filter. These limit cycle oscillations are sometimes associated with the resonant frequency of the output filter. Study this and study your control loop poles. Double check for interaction and change your loop or change your output filter. Loose ferrite cores can also cause audible oscillations despite running far above 20 kHz.

\$\endgroup\$
  • \$\begingroup\$ I used 4 different L (1 ,4 , 7 and 10uH) this noise is always present at 5.5Khz...so I am certain its not from resonance of LC filter \$\endgroup\$ – Johan B. Jun 7 '18 at 8:39
2
\$\begingroup\$

The spectrum of the noise is supplied and here is a copy: -

enter image description here

The noise at 5.5 kHz is a level of 250 uV RMS.

A typical noise/ripple level from a circuit like the one you have is probably around 100 times higher and you appear to be worried by this level.

Yes , we are making it under 1uV (0-20Khz)

The only chance of this happening is if you use a LDO linear voltage regulator fed from the flyback output. Even then I think you are going to struggle.

Take for example the TLV705 that is described by TI as being low noise. It has a quoted noise level of 27 uV RMS across 10 Hz to 100 kHz and it is: -

A LINEAR VOLTAGE REGULATOR AND NOT A SWITCHING REGULATOR

Take the LP5907 as another example. It is described as a: -

250mA Ultra-Low-Noise Low-IQ LDO

Notice my emphasis on the low noise bit. It has a noise output level over a 10 Hz to 100 kHz bandwidth of 6.5 uV RMS.

What you are hoping to achieve is not going to happen with a simple Flyback converter.


MORE CONTEXT

The thermal noise across a 100 kHz bandwidth from a 560 ohm resistor at an elevated temperature of 50 degC (not unheard of in a flyback converter) is 1 uV RMS. At a 20 kHz BW it is about 0.45 uV.

How many resistors have you got in your circuit that are in the signal chain that will add noise to the output? I count 4 and these alone will tip the balance. Be realistic.

\$\endgroup\$
  • \$\begingroup\$ I have not added a active opamp filter that has excellent psrr at 3-10Khz. Right now we are concentrating on reducing that spike as much as possible. \$\endgroup\$ – Johan B. Jun 8 '18 at 11:35
  • \$\begingroup\$ An active op-amp filter won't do what you want - you need a linear voltage regulator following your flyback to stand half a chance of getting the noise down to below 10 uV. Be sensible about this and lower your expectations because you WILL be dissapointed. \$\endgroup\$ – Andy aka Jun 8 '18 at 11:36
  • \$\begingroup\$ Andy we already have the active filter and it works. I will post the results with the filter so you can see it and comment on it. Meanwhile back to this spike.. \$\endgroup\$ – Johan B. Jun 8 '18 at 11:52
  • \$\begingroup\$ Given the small level it's probably a control-system "hunting" artefact that gets there via the feedback loop. A slight over-voltage is produced by the flyback and the switching temporarily goes into a form of burst mode control hence the lower frequency of 5.5 kHz and not the actual switching frequency. This will be normal for this type of circuit and nothing generally to worry about in normal circumstances compared to the ripple voltage seen due to the switching frequency...... \$\endgroup\$ – Andy aka Jun 8 '18 at 13:12
  • 1
    \$\begingroup\$ .... To verify this look at the waveform from the secondary - if it doesn't seem like a regular continual rectangular pulse then it's probably skipping cycles and that's where the lower frequency comes in. \$\endgroup\$ – Andy aka Jun 8 '18 at 13:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.