0
\$\begingroup\$

I'm using SIM900A mini v3.8.2 GSM/GPRS board to make a phone call on certain condition. I have connected the module through CH340 USB to TTL converter to PC (Windows 10) for testing. All Connections are OK. I'm using 5V 2A power supply so no power issues. Connection LED blinks after every 3 seconds means network is connected. Power LED is on without any blinking.enter image description here

And I'm using AT Command Tester software for testing SIM900A functionality.

Issues: 1st issue is that when I call on a number it simply says NO CARRIER or NO Carrier: Call dis-connected. 2nd issue is that it does not send or receive any SMS/Voice Calls.

Note: I have sufficient tariff/balance for SMS and voice calling. And SIM is unlocked.

Different AT commands responses are as follows:

enter image description here

But When I try to make a phone call its response is this:

enter image description here

And when I send a SMS, SIM900A response is as follows:

enter image description here

Now where is the problem..? I also tested AT commands for voice calling in Arduino Terminal manually but problem is same... Is there any 1st time settings or configuration has to be set for successful communication..? like APN , SIM provider settings etc...? or something else...? Please help me about this...Thanks...!

\$\endgroup\$
  • \$\begingroup\$ No one available for answer ... !!! ? \$\endgroup\$ – Tehseen Jun 9 '18 at 19:27
  • \$\begingroup\$ Do you have credit on the sim card? \$\endgroup\$ – MaNyYaCk Jul 4 '18 at 9:19
  • \$\begingroup\$ absolutely Yes... \$\endgroup\$ – Tehseen Jul 5 '18 at 11:07
  • \$\begingroup\$ Seems ok. Can you check the current and voltage when it tries to send SMS or call? When I had one back it would spike upto 1.8A when calling \$\endgroup\$ – MaNyYaCk Jul 6 '18 at 11:43
  • \$\begingroup\$ Have you checked the SIM with a regular phone? electronics.stackexchange.com/questions/364045/… \$\endgroup\$ – filo Nov 3 '18 at 15:12
1
\$\begingroup\$

I understand the problem after all... I guess that this SIM900A module does not working due to our country regulations about IMEI number registration.... This module is imported from China from online shopping website so It is not registered by PTA (Pakistan Telecommunication Authority) that is why I believe they blocked this module and no sim carrier is providing service to this module... So I threw this module in trash after all...

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.