4
\$\begingroup\$

I've just started doing some work for a company doing some CAD work where they use Altium 16. (16.1.10 to be precise.)

I've used umpteen CAD systems over the years, but done very little Altium. I want to change the colours in the schematic, most especially so I have a black background. Now, changing the background to black is easy. However, I cannot find where you then change the colours of the nets, symbol bodies, pin numbers etc etc.

There surely must be a way of doing such a basic thing on what purports to be a very powerful CAD system. In fact if you can change the background to be black, you surely must be able to change everything else from being black. Otherwise you have a black symbol on a black background saying "do not click." (*)

No-one else here has tried to change from the glaring white background, so they can't help me. An hour or so of Googling has found me nowt either.

So, how do I change my colours so I can have green nets, red symbol bodies etc please?

- * With apologies to Douglas Adams.
\$\endgroup\$
5
  • \$\begingroup\$ DXP->Preferences->Schematic (I think - I am now using AD18) \$\endgroup\$ – Peter Smith Jun 11 '18 at 11:30
  • \$\begingroup\$ I have looked through that over and over. There are various tabs within that preferences pop-up that you would think would hold the key to it, but I can see nowhere where you can make these changes. There's a thing where you can change "primitive" colours, but that seems to do nothing, sadly. \$\endgroup\$ – DiBosco Jun 11 '18 at 11:32
  • \$\begingroup\$ Look under 'primitives' altium.com/documentation/16.1/display/ADES/… \$\endgroup\$ – Peter Smith Jun 11 '18 at 11:37
  • \$\begingroup\$ Yep, been there, done that. :) Tried changing those primitive colours and it just makes no difference at all. I feel I must be missing somthing fundamental here. Either that, or you simply can't do this in Altium and it's just not all it's cracked up to be. \$\endgroup\$ – DiBosco Jun 11 '18 at 11:40
  • \$\begingroup\$ @PeterSmith I was wrong about the primitives doing nothing. When you start to lay stuff down after you've changed the primitives, the newly placed stuff is in the new colour. So, it doesn't solve my "problem", but you were right about primitves affecting colour in their own quirky way! \$\endgroup\$ – DiBosco Jun 11 '18 at 15:09
8
\$\begingroup\$

Altium prior to AD18, has a light design scheme.

You can try to change bits and pieces of the UI, but you will continue to fight it.

I'd recommend that you suck it up, stick to the defaults if you would rather be design-productive, and not fight the software at every step.

This may not be what you were hoping for, but after 20 years of Protel/Altium, you learn to pick your battles with this code.

Probable issues after setting every nook-and-cranny up just the way you like it:

  • Printing issues
  • Portability issues
  • Future proof issues
  • Update/upgrade issues (the option to import preferences during and update is a constant source of crashes)

As of yet, it doesn't necessarily get any better with AD18, which defaults to a dark theme, as it has many other issues (like: it is still beta class).

Sorry. Don't fight it. You'll thank me later.

\$\endgroup\$
1
  • \$\begingroup\$ OK, thanks, Chris. That's why you pat the big money I guess: to have difficult to use, unconfigurable software. Just hoping it's not as terrible as the head-bangingly annoying Cadstar! \$\endgroup\$ – DiBosco Jun 11 '18 at 12:50
0
\$\begingroup\$

The problem is that the color of primitives is a property of the primitive, not a property of the schematic sheet as a whole.

For primitives you place directly on the schematic you can change the color by pressing tab and changing the color property. I belive properties you set this way are "sticky"

For existing primitives placed directly in the schematic you can change the color through the inspector.

The problem is components, a component is made up of primitives, but these primitives are not edited directly on the schematic, they come from the symbol in the library.

So afaict changing the color scheme (or heck getting a consistent color scheme at all) requires modifying all the schematic libraries you use.


P.S. I don't see the "style" parameter alexanicity mentions in either AD15 or AD16, so I guess it must have been introduced in a newer version.

\$\endgroup\$
1
  • \$\begingroup\$ If one is really motivated, for non-library widgets, you can make your own toolbar entries that can place tailored items (power ports, ports, wires, net labels, etc). You must dig into the allowed parameters for the toolbar icons (or look at examples). However, my warnings expressed in my answer elsewhere in this post still apply. Don't do it. \$\endgroup\$ – Chris Knudsen Jun 11 '18 at 17:31
-1
\$\begingroup\$

At the risk of sounding doom-monger-y, you will rue the day your company chose to use Altium :) Chris is right, don't try to adapt the software to your preferences too much - it will only play by its own rules.

But, I don't wish to sounds too negative, so let me explain what I would do. Note that I am using Altium 18, so this may not work for you - but I think the underlying principle exists for the last several Altium versions.

Every object on the schematic, as you have no doubt seen, is a number of system properties (If you have not encountered this, click something an press F11, or otherwise summon the "Properties" panel). One of the properties that all schematic objects have is Style, and in one of those there is an option to set the colour of the object. I am able to set whatever colour I like for every object (primitive and anything else).

Doing this one-by-one is tedious, so the second tool to use is to use the filter-select function (right-click->"Find similar Objects"). Using the default search settings globally selects all the items of that type, which you can then set all to the colour you desire. Repeat for each type of object you have (nets, power rails, components, subsheets etc), setting whatever colour you like.

Now I hear you say "but wait, alexandicity, this only helps for things I already placed!". Right you are. I don't know of any way to set defaults such that all future objects have the new colouring. Either copy existing objects (shift-drag-click - the method I use as quicker than going through placement tool) or set the styles as you place things (press Tab with the placement tool selected to set the properties of the thing you are placing)

There may well be a way, as Altium does have a lot of power, but it is likely hidden away and may cause other problems if used. I would also consider contacting Altium support - for all the issues I have with their software, I find their support team to be excellent and responsive!

\$\endgroup\$
2
  • 2
    \$\begingroup\$ If you do this and ever share your design with your coworkers, they will hate you. \$\endgroup\$ – The Photon Jun 11 '18 at 15:56
  • \$\begingroup\$ @ThePhoton: very true. Every time you pass a design to them you'd need to add this answer to it so they know how to undo the damage wrought :) \$\endgroup\$ – alexandicity Jun 11 '18 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.