1
\$\begingroup\$

I have a problem with my MAX232 chip and can't find the solution. The schematic of the chip is in the attachment. The chip is soldered on to a PCB.

I've checked all the connections, the supply voltage and the grounding. The supply voltage is a steady 5V signal and the ground pins of the caps and chip are correctly connected so I'm guessing that isn't the problem.

The strange thing that I found out is that the VS+ pin is 4,5V and the VS- pin is 0V instead of the 8.5V and -8.5V according to the datasheet.

How can this be possible or is the chip burned?

Thanks in advance.

schematic

\$\endgroup\$
7
  • \$\begingroup\$ datasheets suggests smaller capacitors. although it doesn't seem to be the problem \$\endgroup\$
    – user76844
    Commented Jun 15, 2018 at 9:29
  • \$\begingroup\$ Are you using polarized capacitors and connecting them backwards? \$\endgroup\$ Commented Jun 15, 2018 at 9:33
  • \$\begingroup\$ Circuit looks fine. Check for shorts between pins due to soldering. \$\endgroup\$
    – Andy aka
    Commented Jun 15, 2018 at 9:33
  • 2
    \$\begingroup\$ If this is a Maxim MAX232, then Maxim Integrated tech support can help. If it's a defective chip or a counterfeit being sold with Maxim's brand mark then Maxim will definitely want to investigate. (note: I am a Maxim applications engineer) Output T1OUT should definitely not be grounded, that would explain the charge pump being undervoltage. Can you lift pin 14 from the PCB and confirm it really is an internal short to ground? \$\endgroup\$
    – MarkU
    Commented Jun 15, 2018 at 20:31
  • 1
    \$\begingroup\$ This is a chip from Texas Instruments. Before the weekend I ordered some new ones. If soldering a new chip on the footprint doesn't solve the problem, I will definitely contact Texas Instruments to find out what is wrong. \$\endgroup\$ Commented Jun 18, 2018 at 6:23

1 Answer 1

1
\$\begingroup\$

I solderded a new IC on the footprint and my application is working again. The chip somehow must have been damaged due to wrong voltages or ESD I think.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.