I am trying to make a unipolar stepper motor driver circuit. As a development landmark, I am trying to first run LEDs using the driver. Attached is my circuit.

My 555 timer generates regular pulses for the decade counter. The outputs (0-3) of the decade counter is connected to LEDs. Till this point, this works good. All LEDs light up one at a time. Output 4 of the counter feeds back to reset button as my stepper motor has just 4 inputs.

My stepper motor takes +ve on the common wire and needs to get -ve connection on the other 4 wires. Hence, I need to use transistors to connect the -ve of the power rail to the stepper motor.

But when I insert NPN transistors in place of the LEDs, have the output of decade counter fed into transistor base and have the LEDs connected between the collector and positive supply with emitter connected to negative supply, the transistor does not switch on.

What could I be doing wrong? I am using the following components -

12 V DC Supply

555 Timer

4017B Decade counter

2n2222 NPN Transistors

Various resistors between 1K to 10K.

In order to make sure the transistor is in good state, I inserted it into a different bread board. Then connected LED between collector and +ve voltage, connected emitter to -ve and then connected base with 220, 10K and 470 K resistors to +ve. It works. So looks like the transistor is in a good state, its just that the 4017 output is unable to drive it.

Decade counter feeding into transistors

  • 2
    \$\begingroup\$ Try your LED the other way around. Current flows in to the anode and out of the cathode. Also, reduce the base resistor (currently "230 to 470k") to maybe 10 kohms. \$\endgroup\$
    – The Photon
    Commented Jul 6, 2018 at 5:29
  • \$\begingroup\$ @Photon - Thanks for answering this. Yes, I have tried the LED both ways. Ideally, I guess the -ve should connect to collector and +ve should connect to +VCC. It did not work. \$\endgroup\$
    – Anurag
    Commented Jul 6, 2018 at 5:33
  • \$\begingroup\$ Also, I just tried with 220 Ohms to 10K as well, that too, did not work out. \$\endgroup\$
    – Anurag
    Commented Jul 6, 2018 at 5:33
  • \$\begingroup\$ If you tried the LED reversed and tried to switch it on, you applied 12 V to it in reverse. For some LEDs, this could be enough to kill it. \$\endgroup\$
    – The Photon
    Commented Jul 6, 2018 at 5:34
  • 1
    \$\begingroup\$ Only other thing I can suggest is that those original 4000 series CMOS parts are pretty fragile when it comes to ESD. You may have blown the output drivers on that one pin of the counter. \$\endgroup\$
    – The Photon
    Commented Jul 6, 2018 at 5:38

2 Answers 2


Your schematic does not show symbols of LEDs. An LED is a diode, not a triangle. Your first LED connects between the CD4017 output and the +12V supply so it lights when the signal is off (low) , not when it is on (high).

The LED connected to the transistor and through a resistor to +12V lights when the CD4017 output is on (high) only if the base resistor value is correct.

The datasheet of most little transistors shows that it turns on well (saturates) when the base current is 1/10th the collector current. the collector current in the 1k resistor is about 10mA so the base current should be 1mA. But your base current in the 470k resistor is only 0.000024mA which is way too low.

I agree that probably your LED was connected backwards at first which destroyed it.


You said your 555 timer is outputting a signal that is lighting up the LEDs one at a time right? Stepper motors need 2 of their four inputs activated in order to function. See Photo. This photo is all wonky but usually the sequence is, say, Red & Grey, Then Grey & Black, Then Black & Yellow, Then Yellow and Red. Lather, Rinse, Repeat.

Here is a better photo: enter image description here

Image taken from this Stepper motor tutorial from a WordPress article created by Moududor Shamim: https://vshamu.wordpress.com/tag/bipolar-stepper-motor/


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.