1
\$\begingroup\$

I use Quartus II web edition and using that driver my computer can find the card: enter image description here

And the card appears in the device manager so it indeed looks correct so far. enter image description here

But when I start Quartus Programmer to download my logic to the board, the hardware part of the interface is blank where I expect to see my card: enter image description here What can be done? The instructions I have are available here.

Can you help me?

Update

I reinstalled the drivers, reinstalled Quartus II different versions many times, reset the board, tried both the Quartus version from the CD and from the internet, I see many other people have the same problem with the same board, thank you Altera for making us lose valuable time wasting our time on faulty software. Why can't it work? From the command-line I can run a tool named jtagconfig that actually seems to find the board but this is from the command line: enter image description here

Update 2

I reinstalled and ran the program this time with admin privileges and antivirus turned off and then it worked. The DE2 board appears in my Quartus Programmer and I can download the logic to the board.

\$\endgroup\$
1
\$\begingroup\$

Close the programmer and power cycle the board. If that doesn't work, I've also had success using the Windows Reinstall Driver function.

\$\endgroup\$
1
\$\begingroup\$

You have to install the driver manually for the board. Don't let windows install it for you. The driver you need is in Altera's Driver folder. The path on my machine is C:/altera/11.1sp2/quartus/drivers/

\$\endgroup\$
0
\$\begingroup\$

Although the thread is rather old, but this problem exists with some of Altera's product. I still have a DE0 board which uses Cyclone III and no matter how old it is, it works perfectly. However, Quartus has stopped supporting Cyclone III from v14.0 and we want to use windows 10.

Important thing to note is I found out that the driver files came with v12.0 (which I tried to use at that time) are not working with Windows 10. The indication is that they are not signed files and windows should warn about that. But it doesn't show any warning even if you enter TEST mode of Windows 10.

Another thing is that the driver came with Quartus v7.2 is a good one.

So, here are the procedures that worked for me:

1- Install v12.0 (or v13).

2- Don't install the driver.

3- Install v7.2 (my recommendation).

4- Enter Windows 10 test mode. See the steps here.

5- Open device manager and then power on the board (mine is DE0).

6- You will see that USB blaster is listed but it shown as other devices.

7- Try to update the driver by navigating to C:\altera\72\quartus\drivers\usb-blaster and make sure you have checked "include subfolders".

8- You will see unsigned warning. Click to continue.

9- Open Quartus v12.0 and go to toold->programmer->hardware_setup and you will see USB_blaster.

10- Don't forget to turn off windows test mode.

11- Enjoy!

Note that the driver files came with v7.2 is different from v12.0. Please see the picture.

enter image description here

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.