1
\$\begingroup\$
  • Platform: Mac OS X 10.13.5
  • Eagle Version: 9.1.1

For some reason, when I apply my ground pour (draw polygon with name GND and hit ratsnest), the ground pour covers my other components as well as air wires in the Eagle board view.

I don't think I experienced this with other board designs.

Is there something that I'm doing wrong?

enter image description here

Edit: This is what it looks like in an Eagle tutorial: enter image description here

\$\endgroup\$
  • \$\begingroup\$ Looks normal to me. What were you expecting? \$\endgroup\$ – brhans Jul 18 '18 at 0:17
  • \$\begingroup\$ @brhans please see edited post \$\endgroup\$ – Allen Houng Jul 18 '18 at 0:31
  • \$\begingroup\$ To me, it looks like you had put all components on the bottom layer instead of the top layer. Your PCB is upside down. See the BERG label on your USB connector. It's mirrored. \$\endgroup\$ – Janka Jul 18 '18 at 0:37
  • 1
    \$\begingroup\$ I think a tight clearance & low-resolution pic are making it look like the pour is connected to pads it shouldn't be and actually isn't. You can see where it is properly connected to pads by the 'reliefs'. As for the 'air wires' - they're not 'real' - there's no copper to prevent the pour from being there. I'm confused as to why you've poured the ground plane before routing anything else ... ? \$\endgroup\$ – brhans Jul 18 '18 at 1:17
  • 2
    \$\begingroup\$ The air wires are connections not routed yet. It does not make sense to isolate them from a ground pour. Do the routing first and then add a ground pour. At least route 1 or 2 air wires to see the effect on ground pour. Ground pour requires to set the isolation distance before. \$\endgroup\$ – Uwe Jul 27 '18 at 10:05
2
\$\begingroup\$

It's a known, reported bug, first seen over here.

Until a fix is issued in a future update, the only work around by now is running this command in the command line of Eagle:

set Option.LayerSequence 23 1 16
\$\endgroup\$
  • \$\begingroup\$ AWESOME IM GLAD IM NOT CRAZY \$\endgroup\$ – Allen Houng Aug 3 '18 at 2:11
1
\$\begingroup\$

Ensure that the shape for the ground pour was named GND Then hit the ratsnets command.

enter image description here

\$\endgroup\$
  • \$\begingroup\$ confirmed that is what i have. still not working :\ \$\endgroup\$ – Allen Houng Jul 18 '18 at 8:10
  • \$\begingroup\$ @AllenHoung what setting do you have for isolate? If it 0, as shown in the screenshot above, then of course it will cover everything. Isolate is the clearance between the plane and any other traces/pads/planes. \$\endgroup\$ – Tom Carpenter Jul 18 '18 at 10:17
  • \$\begingroup\$ @ConcernedCitizen, you might want to use sensible settings in your screenshots. \$\endgroup\$ – Tom Carpenter Jul 18 '18 at 10:17
  • \$\begingroup\$ @TomCarpenter such as? Having isolate as 0 gives me no issues when i hit ratsnets. It will default to your DRC settings... \$\endgroup\$ – Concerned Citizen Jul 19 '18 at 11:07
  • \$\begingroup\$ @TomCarpenter what's your value for isolate? \$\endgroup\$ – Allen Houng Jul 19 '18 at 12:47
0
\$\begingroup\$

So after trying routing, it seems like this is a new feature in the latest eagle? It seems that eagle will only highlight the specific airwire that you are trying to route as shown in the screenshot below:

enter image description here

\$\endgroup\$
  • 1
    \$\begingroup\$ RTFM Read The Fantastic Manual! From first page to the last. Do it before any further experiments. \$\endgroup\$ – Uwe Jul 27 '18 at 10:10
  • \$\begingroup\$ Or watch some more videos. \$\endgroup\$ – Concerned Citizen Jul 28 '18 at 4:26
  • \$\begingroup\$ @Uwe it's a bug! see solution \$\endgroup\$ – Allen Houng Aug 3 '18 at 2:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.