1
\$\begingroup\$

TL;DR:
I'm working on a project that incorporates (besides other things) two AL5802 linear LED-drivers in parallel. Unfortunately, I felt balsy and had my complete PCB made in China before testing the circuit on a breadboard. Murphy’s law struck and the LED-drivers don't work on the PCB. When trying them out on a breadboard using adaptor-PCBs, they oddly do work perfectly.

Disclaimer: The connection between EN and GND was an error and I fixed it by bending that pin away. I am also very certain that the other components on the PCB don't interfere with the LEDs.

Detailed description:
I have been working on a project for several months now. The most recent addition to my endeavor were two AL5802 linear LED-Drivers. Previously, whenever I was trying new components, I asked my buddy to route a few adaptor boards so I could plug them directly into my breadboard.

With all the other components working together nicely, I decided to expand the functionality of my project by adding said driver ICs, which would then drive multiple LEDs. Unfortunately, I got balsy and instead of having adaptor-PCBs done and playing around on the breadboard first, I added them to my finished Eagle-Board straight away and sent it off to Elecrow to be produced.

After they arrived and me having soldered all the components onto it, everything worked except for the LEDs... Measuring the voltage of the out-Pin showed 0V and the current supplied to the LEDs was (obviously) 0mA.

To make troubleshooting easier, I got adaptor boards routed. Oddly enough, they worked perfectly on my breadboard. When comparing the schematics of the adaptor-boards with the ones I had made at Elecrow, they seem functionally identical.

Question: What on earth have I messed up on my Elecrow-PCB? Is it an error in my layout or have I failed at soldering (I currently don’t have a proper magnifying glass and the lighting conditions in my electronics space are terrible).

Images:

1 - Partial schematic of my Elecrow-Board: Schematic of my Elecrow-Board

2 - Partial board view of my Elecrow-Board:

Board view of my Elecrow-Board

3 - Schematic of my Adaptor-Board:
Schematic of my Adaptor-Board

4 - Photo of the Breadboard-Setup using my Adaptor-Board (I deadbugged the 2nd chip onto a different board):

Photo of Breadboard-Setup using my Adaptor-Board (I deadbugged the 2nd chip onto a different board)

\$\endgroup\$
  • 2
    \$\begingroup\$ Check each schematic net for continuity on the PCB (with no power of course). Something must not ring out that should... or something must ring out that shouldn't... \$\endgroup\$ – vicatcu Jul 22 '18 at 21:56
  • \$\begingroup\$ Report value of R1 and voltage on each pin and test LED polarity. OK? \$\endgroup\$ – Sunnyskyguy EE75 Jul 22 '18 at 22:55
  • 1
    \$\begingroup\$ Although I have checked continuity twice, I must have missed one pin... Although it seemed alright visually, there must have been a dry joint as it didn't make a reliable connection! After going over all the pins with the wide soldering tip once again, it works beautifully! Thanks @vicatcu Unfortunately, I can't select comments as accepted answers... \$\endgroup\$ – iMrFelix Jul 23 '18 at 12:18
  • \$\begingroup\$ @TonyEErocketscientist it was 6.8 Ohm resistor, but that apparently wasn't the issue. A dry soldering joint was \$\endgroup\$ – iMrFelix Jul 23 '18 at 12:19
  • \$\begingroup\$ Ah ok then each is approx 100mA current limiter x2 \$\endgroup\$ – Sunnyskyguy EE75 Jul 23 '18 at 15:57
1
\$\begingroup\$

Just for the sake of you being able to accept an answer, here's my comment as an answer with a tiny bit of elaboration.

Check each schematic net for continuity on the PCB (with no power applied to the circuit of course). Something must not ring out that should... or something must ring out that shouldn't.

If a circuit doesn't act like the schematic suggests it should, always go back to basics and make sure your "as built" circuit actually faithfully implements the schematic (no more, and no less).

\$\endgroup\$
1
\$\begingroup\$

If you are measuring 0V on the output with respect to GND, the LED should be burned out. Possibly it is installed backwards, or not between +5 and the output.

If I read your photo correctly, the white wire should be + and the blue wire -, which is the opposite of how you have marked them.

\$\endgroup\$
  • \$\begingroup\$ Thanks for answering :) The LEDs are not burned out though, they work perfectly in the breadboard setup. Everything's working in the attatched photo, the issue lies solely on when I want to use the driver chip on my online-ordered PCB \$\endgroup\$ – iMrFelix Jul 22 '18 at 23:30
  • 1
    \$\begingroup\$ <sigh> did you measure the voltage across the LEDs? \$\endgroup\$ – Spehro Pefhany Jul 23 '18 at 0:34
  • \$\begingroup\$ Thanks for the input, but the issue turned out to be nothing more than a dry solder joint I must have missed when checking continuity. \$\endgroup\$ – iMrFelix Jul 23 '18 at 12:21
  • \$\begingroup\$ Good you found it. \$\endgroup\$ – Spehro Pefhany Jul 23 '18 at 13:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.