I'm currently running into a rather confusing problem...

I'm trying to power a strip of 60 WS2812 Leds and an NodeMcu/ESP8266 board.

The supply I chose is a 5V/4A supply.

This one to be precise: Meanwell GST25e05-P1J

I got myself some sockets to connect the supply to my circuit.

I already built a similar project here and it works flawlessly.

But in my current project I just can't seem to power the LEDs with that supply. I already tested it on the other circuit and there it works. So it isn't faulty.

But then when I power the current project with the USB from the NodeMcu-Board or with this 5V/10A power supply it works as intended.

I also ordered another batch of power supplies using the same connector but they also don't work.

So I rebuilt the whole circuit on a breadboard and used another of the sockets I had to power it with the same supply and it works without any problems.

So I thought it might be a problem with the socket I built into my case. But when I soldered another socket in there I still get the same result. It just doesn't seem to work.

I will attach a poorly drawn circuit diagram and a picture of the circuit in its case. (Yes I know it's ugly :/)

Is there anything I can do to fix that? I just can't think of any other reason why this should not work. Especially when everything works fine when I don't use the socket i added.

I already measured the voltage with an oscilloscope but it seems stable to me. So no drop because of the load or any weird interference on the output.

I really need help here :/

If you need any other info or better clarification or whatnot please tell me and I will try to update as soon as possible.

Or if you know a better place to ask this I also welcome any suggestion on that part :)

circuit diagram the build

  • \$\begingroup\$ what kind of sockets are you trying to use? \$\endgroup\$
    – Navaro
    Jul 29, 2018 at 0:38
  • \$\begingroup\$ I currently use some that look like these: images-na.ssl-images-amazon.com/images/I/… \$\endgroup\$
    – Daniel
    Jul 29, 2018 at 12:00
  • \$\begingroup\$ @Daniel - Unfortunately there are too many details missing - and there isn't enough room in a comment to list them all. You seem to have at least 2 variants which do work with that PSU ((a) your "similar" design and (b) this design re-built on a breadboard). One troubleshooting approach would be to concentrate on finding all of the differences between each of those working designs, and your non-working design. One (or more) of those differences must account for the change between working & not working. You have a 'scope so, again, compare equivalent nodes between working & non-working. \$\endgroup\$
    – SamGibson
    Jul 29, 2018 at 13:31

2 Answers 2


Some ideas:

1) Remove the LED strip and continue to test the 5V/4A power supply with your ESP8266 board. Make a single LED flash for testing. Does the ESP8266 board work ok? Power cycle and wait between cycling and confirm the ESP8266 works every single time.

2) Then attach the LED strip. Does the ESP8266 continue to work during each power cycle?

3) Suspecting that you have in-rush current taking place here and is causing the 5V/4A power supply to dip. Could be the quality of the power supply although you are noting that standard USB port is able to power your LED strip? That is a very high current draw for your LED strip if you are selecting a high intensity for your LEDs. The very first thing I would do in the ESP8266 code that is driving your LED strip is to turn on a single RGB LED or a few but only at a visible but dim level.This is to reduce the start up current draw from your power supply. Does that work for you?

  • \$\begingroup\$ 1) already tried that. Everything works fine and I can even use the webpage i host on there to set the leds. 2) also works the same as 1. 3)I start with the leds off. so that should not be a problem i guess. And when I use USB or the other supply I mentioned it works without a problem. I also tried a small test program to just light 1-4 leds but didn't work either \$\endgroup\$
    – Daniel
    Jul 28, 2018 at 22:21

Presumably the "sockets" that you mention are the DB9 dual row (5 pin and 4 pin) connectors on the lower panel in your photo. These are effectively just "pieces of wire" and there should not be anything 'magical' about them that causes problems. This suggests that you are not doing what you think you are somewhere in the system.

The only potentially marginal part of the circuit is the serial data transfer. The power supply and ground should be right or wrong. So -

Use an Ohm meter to determine that connections all are correct. Measure from end to end of each "net". eg Ground continuity from PSU to all destinations. If all OK, then -

Apply 5V and measure voltage between 5V and ground using ALL combinations of 5V and ground. ie you have 5V and ground connections at PSU, mcu, disp1, disp2. So there are 16 combinations - while it is unlikely that a high resistance (or wrong) connection would not show fairly obviously, it may. If all OK then -

Ensure the 400 Ohm resistor IS a 400 Ohm resistor (or what the data sheet says). Short circuiting it may make a difference in marginal cases.
Ensure that the RX signal (which I'd have thought would be called TX) is at the correct level wrt ground as measured at each display. If it appears OK, disconnect the second display (the one daisy chained to the mcu via display1)to see if it works. If not, hard wire from the RX (TX?) pin via a new resistor to the display1 Di pin. If tghis works with display 2 connected/disconnected try hard wiring from display1 Do to display2 Di.

etc ...
The approach is to start with the easy and obvious, prove that what you think you have is what you actually have and extend outwards. By hardwiring various signals you step by step back convert to the arrangement that you know worked. After enough changes you will get back to a known good arrangement. Along the way it should start working when you identify the or a problem.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.