0
\$\begingroup\$

Has anyone had any experience interfacing the TLV5606 DAC with a microcontroller (via SPI)?

I'm having trouble getting any output from the DAC, which I suspect is down to my code.

Does anyone have sample code on communicating with the TLV5606 via SPI? Ideally looking for LPC1768 code, but at this point, anything in C/C++ on any MCU will be a blessing.

\$\endgroup\$
  • \$\begingroup\$ First, you need to show what you already tried. Second, there is nothing special about this ADC. It does not have data output, but neither a lot of other chips, and anyway SPI does not care. So any SPI code example will do just fine for you, as long as you send correct commands. And for that just read a datasheet. \$\endgroup\$ – Maple Aug 5 '18 at 0:03
0
\$\begingroup\$

Keep in mind that TLV5606 is expecting SPI mode 1 (CPOL=0, CPHA=1) and FS pin is used as SS input, while CS should be permanently tied to ground.

As for code samples - any code that sends SPI commands should work for you.

\$\endgroup\$
  • \$\begingroup\$ If you check my previous question, I posted the code there. Still having loads of problems... \$\endgroup\$ – 19172281 Aug 5 '18 at 1:17
  • \$\begingroup\$ Your previous question refers to different ADC and has code peppered with meaningless leftover comments from original source. Clean it up and post here. Note that adding comments that describe what each line actually means might help you find a problem yourself. \$\endgroup\$ – Maple Aug 5 '18 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.