0
\$\begingroup\$

I recently purchased a rather inexpensive LPC1768 development board from dx.com. The board can supposedly be programmed via USB (in a similar fashion to the mbed).

To open the device as a disk, you hold the KEY button, and plug the board in. Opening the device, there is a firmware.bin file.

I first tried copying an LED blink demo bin file over, but an error appears informing me that there is insufficient space available (keep in mind that the program is tiny, as you would expect). I then tried deleting the firmware.bin file, and copying the demo program over again, this time working fine. However, when the board is reset, or board turned off/on, the demo program disappears from the drive, and firmware.bin returns. So, it seems that on reset, the board reverts to it's initial state.

Does anyone have an explanation for this, and a workaround? Anybody with experience of this particular board? There was no documentation issued with the board, and nothing I can find online.

http://www.dx.com/p/lpc1768-arm-cortex-m3-scm-board-148988#.W2h14thKjBI

\$\endgroup\$
  • \$\begingroup\$ Does it blink ? \$\endgroup\$ – Long Pham Aug 6 '18 at 16:30
  • \$\begingroup\$ @LongPham, sadly not \$\endgroup\$ – 19172281 Aug 6 '18 at 16:34
  • \$\begingroup\$ Which pin is the led connected to ? Have you modified the demo accordingly? \$\endgroup\$ – Long Pham Aug 6 '18 at 16:49
  • \$\begingroup\$ @LongPham, LED is connected to p.18, which corresponds to pin 6. \$\endgroup\$ – 19172281 Aug 6 '18 at 17:20
  • \$\begingroup\$ What is the port number? Where did you find the demo ? Is it a demo of some official dev board ? The led pin may not be the same with those dev board. So you should check and change accordingly. \$\endgroup\$ – Long Pham Aug 7 '18 at 3:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.