0
\$\begingroup\$

I am working with an older version of Altium (V09).

I have this popup every time I want to move a part in a PCB doc. enter image description here

I have the sch and the pcb open and I changed some parts in the sch and to update in the pcb, you need to delete the 'old' part and then update the pcbdoc by clicking Design > Import Changes From...

Then click Yes on the failed to match popup: enter image description here

And then I click execute changes and this popup comes: enter image description here

I waited for more than 20mins and then clicked cancel but then the Comma expected error pops up every time I try to move something.

I have tried closing Altium and opening it again. But this didn't help. I have not tried uninstalling and reinstalling, but I would like to avoid that as a solution.

Any ideas on how to fix the comma expected error?

\$\endgroup\$
  • 1
    \$\begingroup\$ Does this happen for a specific design or component only or is it consistent over all your designs? V09 is heavily outdated \$\endgroup\$ – Humpawumpa Aug 10 '18 at 11:58
  • \$\begingroup\$ Is this version of Altium legitimate or is it cracked? \$\endgroup\$ – DerStrom8 Aug 10 '18 at 12:00
  • \$\begingroup\$ It is legitimate, and I can't afford to get an update as it is really expensive. I will need to check with the other projects but so far it is will every component. \$\endgroup\$ – Gareth T. Aug 10 '18 at 12:11
  • \$\begingroup\$ Try creating a new project, schematic, PCB (a very simple one) and see if the problem persists (close all the files in your current project). Try creating a new project and add the existing schematic and PCB files. It's possible you have a corrupted project, schematic, pcb or library file. \$\endgroup\$ – Spehro Pefhany Aug 10 '18 at 12:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.