2
\$\begingroup\$

I've soldered the AT90USB1286 Chip on a PCB like on this circuit: Imgur

Schematic

If I measure the pins, caps, resistors etc. with a multimeter, everything seems to be powered and fine. Reset button pulls to ground. And yet, the computer doesn't recognize any USB device when I plug the USB cable in.

I've tried it on Mac and a Linux PC. lsusb doesn't show anything new after plugging in. Same goes for Mac.

Does anyone have an idea how to troubleshoot this? How to get this chip recognized over USB? Thanks a lot.

\$\endgroup\$
  • 1
    \$\begingroup\$ How is the reset pin? High or Low? According to datasheet the reset Pin is low active \$\endgroup\$ – Alexander von Wernherr Aug 14 '18 at 7:59
  • 1
    \$\begingroup\$ Why is Vbus disconnected? \$\endgroup\$ – Richard the Spacecat Aug 14 '18 at 8:21
  • \$\begingroup\$ Is a clean blank chip? Who do you expect to control the USB peripheral, you need to load a bootloader or something like that using a programmer first. \$\endgroup\$ – Dorian Aug 14 '18 at 8:27
  • \$\begingroup\$ @Dorian Thought the same, however by the datasheet, it seems like the chips come preprogrammed with an USB bootloader. \$\endgroup\$ – Richard the Spacecat Aug 14 '18 at 8:30
  • 1
    \$\begingroup\$ Thanks for the quick responses! Yes the xtal is 16 Mhz. It is a clean chip, but I also thought that a bootloader is preinstalled, after reading the datasheet. And the Reset pin is High by default. When pressing the switch, it is pulled to ground (low). I've measured this by multimeter, it works. 5V high, 0V low... \$\endgroup\$ – Mig Bugmajor Aug 14 '18 at 8:45
6
\$\begingroup\$

Leaving the Vbus pin floating seems a bit strange.

The datasheet shows this configuration: enter image description here

None of the configurations shown in the datasheet leaves the Vbus pin floating. Just try connecting it up and see if that helps anything.

\$\endgroup\$
  • 1
    \$\begingroup\$ That would be the problem - "The USB peripheral cannot attach to the bus while VBUS bit is not set." - if VBUS is low (likely if it is floating), the USB peripheral won't connect. \$\endgroup\$ – Tom Carpenter Aug 14 '18 at 8:39
  • \$\begingroup\$ Thanks for the hint! It is not really floating, all VCC connections are connected to each other. I've built the board after this manual: github.com/ruiqimao/keyboard-pcb-guide And power seems to be everywhere it should...that wouldn't be the case if this was floating, right? \$\endgroup\$ – Mig Bugmajor Aug 14 '18 at 8:52
  • \$\begingroup\$ @MigBugmajor The issue isn't about VCC pins, those are fine. The VBUS pin is the issue, I suspect. (Which, the tutorial shows as connected to VCC. You, on the other hand, have it floating. It's the pin 8 on the schematic you have provided) \$\endgroup\$ – Richard the Spacecat Aug 14 '18 at 9:04
  • \$\begingroup\$ Oooooh now I see it! Holy crap. That has to be it. Thanks so much for the help. I will connect it tonight and report if it worked \$\endgroup\$ – Mig Bugmajor Aug 14 '18 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.