4
\$\begingroup\$

I have recently designed an audio player that uses the TI TPA3112D1 power amplifier, and mostly based it on the reference design and schematic. I find however, that the design is failing the conducted emissions test due to noise feeding back into the 24VDC supply. This noise starts at 340khz with harmonics present proceeding up the freqency range. I assume this to be from the amplifier, as the noise is starts as soon as the amp is unmuted. The noise is present regardless of audio level output of the amplifier.

I have tried adding different types and variations of bypass caps, which seems to have really no effect. I also tried a 12uh inductor (AISC-1210HS-120K-T2) I had on hand on the positive supply input, which also made no noticeable difference. The test house also tried a Steward LFB310190-000, which made little difference.

The PCB is a 6 layer board, the pictures below don't include layers 3 and 4, as there are no traces or planes close to the power and power amp circuit.

The power circuit uses a common mode choke, which probably doesn't target these low freqencies at all.

Googling this is largely ineffective, as most app notes are geared towards emi on the output side of a Class D amp. It may be I need low freqency filtering of some sort, but it isn't clear to me.

Amp schematic

Conducted emissions results

Top layer 1

Ground layer 2

Power layer 5

Bottom layer 6

Power amp datasheet

Steward filter

My own lab results

My results My DSA

Pre and Post 12 uH inductor, prior to common mode choke

12 uH inductor

24V + and -, with A-B, at output, through common mode choke(It would almost appear to amplify these signals!?)

24v -+ math

Attempted fix 1

In this fix, I have cut the traces between the via and the sm caps, routing the supply through the cap leads. This cap is a 470uf 35v electrolytic. I have also double stacked 1nf and .1uf on each side.

L4 and L5 are part HI0805R800R-10

Original C12 and C64 100uf 50v are part UCD1H101MNL1GS Changed to 470uf 35v EEU-FR1V471L

C29 and C13 1nf 50v are part C0402C102K5RACTU

C30 and C31 0.1uf 50v are part C0603C104K5RACTU

Results are no better, probably slightly worse. The most noticeable difference is caused by touching output leads or speaker body, which causes these spikes/harmonics to approximately double in amplitude. This would seem to indicate that output filtering (L4 and L5) play a part in how this works.

enter image description here

Probe setup

enter image description here

\$\endgroup\$
12
  • \$\begingroup\$ Can you see any differential 340 MHz signal on any rail due to inadequate filtering? Did you by any chance saturate your inductor/do you see any difference at lower power? \$\endgroup\$
    – winny
    Aug 15 '18 at 21:42
  • \$\begingroup\$ There is a perceptible difference in that higher audio levels slightly lower some sub harmonics, but if the chip is unmuted with very low or no output the noise is present. \$\endgroup\$ Aug 15 '18 at 22:25
  • \$\begingroup\$ I'm not sure I understand your question about differential on a single rail? I'll attach my own test setup. \$\endgroup\$ Aug 15 '18 at 22:38
  • \$\begingroup\$ Do you have enough decoupling? If you set your scope to AC coupling and probe +24 V rail, what does it look like under load? \$\endgroup\$
    – winny
    Aug 16 '18 at 6:00
  • \$\begingroup\$ Added 24v rail shots. \$\endgroup\$ Aug 16 '18 at 13:19
2
\$\begingroup\$

Do re-read the datasheet:

The TPA3112D1 is a high-performance CMOS audio amplifier that requires adequate power supply decoupling to ensure that the output total harmonic distortion (THD) is as low as possible. Power supply decoupling also prevents oscillations for long lead lengths between the amplifier and the speaker. Optimum decoupling is achieved by using a network of capacitors of different types that target specific types of noise on the power supply leads. For higher frequency transients due to parasitic circuit elements such as bond wire and copper trace inductances as well as lead frame capacitance, a good-quality, low equivalent-seriesresistance (ESR) ceramic capacitor from 220 pF to 1000 pF works well. This capacitor must be placed as close to the device PVCC pins and system ground (either PGND pins or PowerPAD) as possible. For mid-frequency noise due to filter resonances or PWM switching transients as well as digital hash on the line, another goodquality capacitor typically 0.1 µF to 1 µF placed as close as possible to the device PVCC leads works best. For filtering lower frequency noise signals, a larger aluminum electrolytic capacitor of 220 µF or greater placed near the audio power amplifier works well. The 220-µF capacitor also serves as a local storage capacitor for supplying current during large signal transients on the amplifier outputs. The PVCC pins provide the power to the output transistors, so a 220-µF or larger capacitor must be placed on each PVCC pin. A 10-µF capacitor on the AVCC pin is adequate. Also, a small decoupling resistor between AVCC and PVCC can be used to keep high frequency, Class-D noise from entering the linear input amplifiers.

Get at least 220uF low impedance cap. Also here are a few pointers to your layout. 3 circles in red, traces to thin to deliver higher power. 2 arrows in orange, shift the via holes to a new location; punch at least 3 vias per side. Layout examples in page 23 is better to follow for first prototype.

enter image description here

\$\endgroup\$
1
  • \$\begingroup\$ This answer would assume that if you did perfect decoupling that the results would be perfect? What if the switching is too good, could the problem be caused by output load? \$\endgroup\$ Aug 16 '18 at 18:29
0
\$\begingroup\$

the design is failing the conducted emissions test due to noise feeding back into the 24VDC supply

This requires some source impedance in order to achieve any attenuation with C12,C29,C31 for 100uF, 100nF , 1nF.

If the source impedance of the supply is lower then noise is not attenuated as much.
A low ESR ceramic 1 uF may be better than 100nF > 1MHz

Here is a solution using 10uH.

\$\endgroup\$
3
  • \$\begingroup\$ Any particular reason you would focus on the avcc rather than pvcc as the source of noise? \$\endgroup\$ Aug 15 '18 at 23:40
  • \$\begingroup\$ Is this for differential noise or common mode? \$\endgroup\$ Aug 16 '18 at 0:17
  • \$\begingroup\$ See new 24v rail captures, It seems like a bit of both. AVCC probed on AC shows disturbance as external to the 10R resistor, or coming from the main 24v rail. \$\endgroup\$ Aug 16 '18 at 13:19
0
\$\begingroup\$

Nothing like having skin in the game, so I am posting this as none of the other answers really targeted the core problem.

This is after all a high performance chip, so that means fast switching to a load is going to reflect right back to the PVCC, and no amount of power input filtering is really going to mute this level of noise. This answer on the TI forums points to that assumption. So in the vein of that answer I put 15uH and 0.47uf reconstruction filters on the output rather than the ferrite bead filter.

Original part scan: Original part

Modified part scan: LC reconstruction filter

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.