What I did, step by step:

  1. Cut off the USB-A cable from a device. (smart card reader)

  2. Cut a USB-C to USB-A cable in half. (cable came with a phone)

  3. Soldered the USB-C part (see step 2) to the device (see step 1):

    Photo of connected USB-C cable

  4. Connected the device to my phone: It was not detected. (lsusb in Termux)

  5. Cut a USB-A to Micro cable in half.

  6. By soldering, replaced the USB-C cable with the USB-A cable from step 5. (In case you wonder: I could’ve used the original cable from step 1, but that was already destroyed as I tore it apart – see below.)

    Photo of connected USB-A cable

  7. Connected the device to my phone using a USB-C to A adapter. Now it worked.

What did I do wrong?

Now I read in an answer that one should do some connections via a resistor. However:

  • I tore the cable from step 2 apart:

    • The USB-A part contains no resistor. Furthermore the colors of the wires exactly matched the standard USB-A pin out.

    • The USB-C part contains some electronics. There is a component labeled D9 and another very tiny component possibly labeled R1. It looks like that tiny component bridges the white and the green wire. It’s hard to see because it is all covered in glue which is almost impossible to peel off.

  • On the web, I found advertisements for USB-C to USB-A cables that mention the resistor being part of the USB-C plug. I assume this is standard practice.

I don’t understand what went wrong. The solder connections were certainly good. In fact I redid them, then tried again, got the same result. Also I was very careful not to short any connections, except for intentionally shorting the two black wires once: no difference

  • 1
    \$\begingroup\$ This is unanswerable, as you've provided no meaningful documentation of what you did. Just about anything could be wrong. One thing that does stand out is that you seem to have assumed the wires in the donor cable and device consistently followed some norm of color code, when in practice is no consistently followed standard for this. If you want to actually solve this, document which contact in the connector was connected to which signal role on the board. \$\endgroup\$ – Chris Stratton Aug 21 '18 at 13:20
  • \$\begingroup\$ Also to debug a faulty USB device look in dmesg output. No response often indicates a power problem or disconnected data wires. A full speed device failing to enumerate as low speed or a low speed device failing to enumerate as full speed often indicates swapped data wires (ie, the detect pullup on the wrong line) \$\endgroup\$ – Chris Stratton Aug 21 '18 at 13:24
  • \$\begingroup\$ @ChrisStratton I didn’t mention, but I did tear apart the original cable as well. The colors matched the colors in the other cables. \$\endgroup\$ – feklee Aug 21 '18 at 13:38
  • \$\begingroup\$ @feklee - While it may not be your issue here, just because you had the same variety of colors doesn't mean their roles match. Unless you actually verify that with an ohm meter to the connector contacts, it's not a safe assumption, and when something goes wrong, you have to check all the assumptions. I've seen black be VBus and red be Ground. Cables aren't designed to be cut up, so making sure the machine gets loaded with the theoretically right color rolls in the right places isn't really a priority. \$\endgroup\$ – Chris Stratton Aug 21 '18 at 13:40
  • 2
    \$\begingroup\$ @ChrisStratton I did tear everything apart, incl. the plugs (lots of glue) till I could visually see the connections of the cables to the pins. It was all consistent in all the cables. Still, thanks for mentioning that the colors should not be trusted! \$\endgroup\$ – feklee Aug 21 '18 at 13:44

I don’t understand what went wrong.

What went wrong is that you cut a wrong type of Type-C cable. From your imprecise description you took a part of Type-C to Type-A PLUG cable. This kind of cables are designed to connect a USB Type-A HOST to Type-C device. So essentially the cable must fake the USB host signature. It is doing so by having PULL_UP resistor on CC line to VBUS, typically 56k.

Yours is a device, so the captive Type-C end must have "device" signature, which is 5.1k PULL DOWN on CC pin. To make it work you need to get an OTG adapter, Type-C to Type-A RECEPTACLE, like this one,

enter image description here

and do the same soldering work. Before cutting and soldering, make sure that the adapter works with the phone (use a pen drive or mouse), some adapters don't have proper pull-downs and don't work.

  • 2
    \$\begingroup\$ @feklee, alternatively you can get a regular C-C cable, solder green-white-red-black wires as you did, then identify which wire goes to CC pin (should be Blue, but...), and pull it down with 5.1k on the side of your rework. It might be a bit more expensive though, since you would need a Type-C break-out receptacle to identify/verify the CC wire. \$\endgroup\$ – Ale..chenski Aug 21 '18 at 14:08
  • \$\begingroup\$ Got an OTG cable (Anker A8165), and it works! I soldered red to Vbus, white to DP, green to DM, and the two blank wires together to GND/SHLD. There are four more wires (yellow, blue, orange, violet) that I ignored. There is no black wire. \$\endgroup\$ – feklee Aug 26 '18 at 8:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.