0
\$\begingroup\$

A few days ago I started to learn Altium Designer 17 and immediately stumbled upon some strange behavior. I created my first component and decided to see how it will look on paper. So I added this component to a schematic sheet, set the sheet size to A4 (look at the screenshot below), tried to print it, and... got not what I expected.

enter image description here

I began to look for the causes and noticed that the sheet on my screen has the wrong proportions! Approximately 0.66 instead of 0.707 for A4. When I ticked "Use Custom Style" and set all the sizes manually, the problem was solved. Okay, that's good, but why the standard style called A4 doesn't work? I tried to do the same thing in Altium 18 and got the same result.

It is interesting that in the "Tools->Schematic Preferences" dialog you can set the default sheet size. If you set this size to A4, the parameter called "Drawing Area" becomes equal to 292x193mm, which gives us this weird 0.66 ratio. So... This is not a bug. But what is it?

enter image description here

To make it more clear I made a screenshot. Here is my schematic sheet. In the document settings, the size of the sheet is set to A4 (see the first picture in my question). According to the standard, A4 has 0.707 height/width ratio, but neither A/B nor D/C equal to 0.707!

enter image description here

\$\endgroup\$
1
\$\begingroup\$

Printing is different from the (virtual) document size. The schematic document size sets the proportions and the mapping from the symbol size to document.

The printed page dimensions and scaling are set by File->Page Setup. You probably would want to set the two the same. The default is probably 'letter' (215.9mm by 279.4mm) not 'A4' (210mm by 297mm).

enter image description here


Edit: You can see the print area by right-clicking in the preview pane and selecting appropriate options. The available area changes with the selected printer. It does appear that, for whatever reason, they've chosen to make the aspect ratio a bit different from that of the paper, leaving a few mm more space top and bottom.

Of course when you make your own template (which you would definitely want to do, to include your company logo and your custom title block) you can alter it if you want.

enter image description here

\$\endgroup\$
  • \$\begingroup\$ This printing dialog raises many questions, but as for the issue being discussed, it is not about printing, it is about the wrong virtual document size. Try to set the virtual size using "Standard Style: A4" and measure the width and height of the sheet, right on the screen. You don't need absolute numbers, just calculate the height/width ratio. It will be 0.66, and that's not A4. \$\endgroup\$ – Dmitry Aug 28 '18 at 17:34
  • \$\begingroup\$ Now go to the same dialog, set the size using "Custom Style, Width: 297mm, Height: 210mm", and once again measure the width and height of the sheet on your screen. Calculate the height/width ratio, it will be 0.707. Now that's what I call A4! So why the standard style named 'A4' actually not A4? \$\endgroup\$ – Dmitry Aug 28 '18 at 17:34
  • \$\begingroup\$ Not sure what's the issue here. When you take away the standard 20mm printing margins from an A4 the aspect ratio of the remaining usable area will be (210-40)/(297-40) = 0.66. That's what you see on the screen. \$\endgroup\$ – Spehro Pefhany Aug 28 '18 at 18:34
  • \$\begingroup\$ I made an explanatory screenshot, please see additions to my question. \$\endgroup\$ – Dmitry Aug 28 '18 at 19:10
  • \$\begingroup\$ Oops! I didn't noticed the information you've added, and I posted the answer I got from one guy on the EEVblog forum. He said the same thing - this is just another Altium quirk or bug, you can call it whatever you like. \$\endgroup\$ – Dmitry Aug 30 '18 at 17:49
0
\$\begingroup\$

T3sl4co1l from EEVblog forum gave me the answer, so I'll just quote him.

Altium's defaults are all wrong. No idea how or why, they just are.

(US) Letter has the wrong aspect ratio in the other direction, so it's not just like they're accounting for paper margins or something.

Just set a custom size, using the actual standards. You probably want to make your own templates anyway, for default parameters, title block, logo or what have you. It's not a big deal, and sharpens things up.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.