0
\$\begingroup\$

I have the following chip (DRV8833) Technical documentation enter image description here

The inputs work the following way

enter image description here

And i have connected it the following way (I think)

schematic

simulate this circuit – Schematic created using CircuitLab

enter image description here

It worked the first time i turn everything on and toggled the GPIO pins, but the second time i started everything up nothing works and the same thing has happend to me with a DRV8838.

So i must be doing something totally wrong to render the chips unusable but what?

I have checked all connections with a multimeter by putting a cable in the breadboard and testing the connection between it and the each pin on the chip (moving the cable for each pin).

I have also tried to connect the motors to the power source and they work.

\$\endgroup\$
  • 2
    \$\begingroup\$ First thing that I notice from your breadboard picture: Is it true that you did not connect the two blue GND rails on your breadboard? This might be the problem. \$\endgroup\$ – Stefan Wyss Sep 3 '18 at 21:10
  • \$\begingroup\$ You are right I will try that tomorrow! \$\endgroup\$ – Peter Sep 4 '18 at 20:59
1
\$\begingroup\$

enter image description here

Figure 1. The datasheet shows the current sense resistors.

enter image description here

Figure 2. Since the resistors are in the path to ground omitting them isn't an option.

enter image description here

Figure 3. A close-up of the missing resistors.

Section 8.3.3 explains the operation of the circuit mathematically.

The PWM chopping current is set by a comparator which compares the voltage across a current sense resistor connected to the xISEN pins with a reference voltage. The reference voltage is fixed at 200 mV. The chopping current is calculated in Equation 1.

$$ I_{CHOP} = \frac {200 \ \text {mV}}{R_{SENSE}} $$

Example: If a 1 Ω sense resistor is used, the chopping current will be 200 mV/1 Ω = 200 mA.

Now recalculate if you omit the resistors. RSENSE becomes infinity so ICHOP becomes zero.

Use the formula to calculate an appropriate resistor value.

\$\endgroup\$
  • \$\begingroup\$ I added 1Ω resistors to both AISEN and BISEN, and that made A work again but not B, could i have fried the chip when running it without the resistors? I have also tried to switch the motors and the resistors but no matter what i change i only get A running.. i have also verified that both GPIO outputs still work with a LED. \$\endgroup\$ – Peter Sep 4 '18 at 20:00
  • 1
    \$\begingroup\$ Leaving out the resistor should just disable that motor. I can't see how you could damage the chip like that. I think your approach is correct so your diagnosis probably is too. \$\endgroup\$ – Transistor Sep 4 '18 at 20:23
  • \$\begingroup\$ how would you debug this? I'm quite new to electronics, i have checked all connections and they seem fine, i even tried to replace the chip, (this one was also connected without the 1 ohm resistors) but same issue happens. What bugs me the most is that i had everything up and running without the 1 ohm resistors the first time i tested(but only with one of the chips), and if i understand correctly the motors should not run without the 1 ohm resistors? \$\endgroup\$ – Peter Sep 4 '18 at 20:31
  • 1
    \$\begingroup\$ I don't know that I can help you much further from here (Ireland). I presume you've tried swapping the pulse inputs to the board. You didn't answer Stefan's comment under your question. You might be connecting the two grounds through the stepper board and that would suffice but you should check and confirm. \$\endgroup\$ – Transistor Sep 4 '18 at 20:57
  • \$\begingroup\$ well after connecting the gnd everything is up and running, thanks for the help \$\endgroup\$ – Peter Sep 5 '18 at 17:48
2
\$\begingroup\$

The loop must be closed with a proper low shunt resistor (eg1 to 0 Ohm) on Isense A/B to gnd.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.