0
\$\begingroup\$

i'm sorry for the previous image. This is my entire circuit .

Here I solved most of my doubts from this site.Thanks to you all and cos of that I come this far.

1 . I wanna cycle through the various color LEDs using clap .

2 . I use a switch to cycle through the effects of LED so I used another 4017 to switch the power supply through 555 and the output of the 555 is amplified using bc547. I hope so.

and this is where I got a doubt

I made the exact same connection. 8 and 13 to ground and 16 to +ve source. That's it. but LED randomly started glowing . If i apply ground to LED's ground it acts pretty normal but it automatically cycles through various pins. and each pins contains 3 LED in series . incl rainbow LED. I'm using 9v 6f22 battery.

\$\endgroup\$
  • \$\begingroup\$ Based on your link to a diagram the IC cannot source enough current to light any LED's except the ones called "High Efficiency". \$\endgroup\$ – Sparky256 Sep 11 '18 at 6:05
  • \$\begingroup\$ What is pin 14 connected to? \$\endgroup\$ – Transistor Sep 11 '18 at 6:23
  • \$\begingroup\$ It's connected to output of 555 .. but I left it disconnected to check if the 4017 is working as expected... Actually I left the LEDs -ve disconnected too... \$\endgroup\$ – Ram Sep 11 '18 at 6:38
  • \$\begingroup\$ If you leave pin 14 disconnected then the 4017 will clock with any noise on the pin. If it's picking up mains frequency noise it could be clocking at 50 or 60 Hz. Never leave CMOS inputs floating. Tie them high or low or use a pull-up or pull-down resistor. There are many schematic editors available that will enable you to draw much better schematics. \$\endgroup\$ – Transistor Sep 11 '18 at 12:19
  • \$\begingroup\$ Thank you very much to you and everyone. Sounds like the problem is only the floating lines. Like you all said I solder it on a PCB and the problem is not happened but when I put some bunch of wires it starts leaks. I'll keep in mind not to float the pins . Again Thank you all . \$\endgroup\$ – Ram Sep 11 '18 at 12:31
0
\$\begingroup\$

You left the leds floating. An unconnected pin can float between voltages and may be able to conduct to ground, completing the circuit. Or you connected them to ground via your skin or the table or moisture, etc. This is why you should never leave something floating, connect it to a voltage source directly or with an appropriate load resistance.

|improve this answer|||||
\$\endgroup\$
  • \$\begingroup\$ Okay...I desolder everything and put a positive voltage to an output pin and every pin is giving the same voltage without a loss... Is it natural? And what exactly to do? (I didn't even connect anything but only IC's power source ) I didn't touched it and only LED terminals are left open...I insulated everything... \$\endgroup\$ – Ram Sep 11 '18 at 5:30
  • 1
    \$\begingroup\$ Passerby meant to say you should never leave inputs floating. Never connect an output directly to ground or to supply + because that will cause high currents to flow if the output tries to switch to the other polarity. By accepting the answer you have indicated that your problem is solved but your comment says it isn't. You can unaccept if you have not solved yet. \$\endgroup\$ – Transistor Sep 11 '18 at 6:07
0
\$\begingroup\$

As an added note to Passerby's answer the CD4017 can only source or sink about 5 mA at most. Suggest using high efficiency LED's or add a buffer IC such as a ULN2803 / ULN2804, which is open collector and can sink 500 mA per output. To run 10 LED's you will need 2 of the 8 channel ULN2803/4 series. No heatsink needed. Will run up to 10 LED's in series per channel.

|improve this answer|||||
\$\endgroup\$
  • \$\begingroup\$ I'm using bc547 to trigger the power for LEDs.. thanks for the buffer IC I'll note it 😊... But why it means floating and everything works fine but that leaky current.. Like I said earlier I powered the IC only.. The terminal of the led's ground is not connected....I think I'm really low for it 😐.... Please tell me what to do.. \$\endgroup\$ – Ram Sep 11 '18 at 5:38
  • \$\begingroup\$ Honestly, without a diagram or a sketch of what you have we are having trouble determining what is connected to what. With a diagram we can offer more suggestions. Thanks for the 'almost' accept vote. \$\endgroup\$ – Sparky256 Sep 11 '18 at 6:02
  • \$\begingroup\$ Yeah..sorry for that... I'll upload it... \$\endgroup\$ – Ram Sep 11 '18 at 6:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.