0
\$\begingroup\$

I'm trying to command a Solid State Relay with the HV1 pin, I can't connect it directly(HV1 to CH1) due to the fact that the impedance on that pin is too low and I only obtain 2.8V when connected.

So, I'm trying to use an NPN transistor(Q1). However, being inexperienced with tranistors I'm not sure that my schematic is correct(probably not).

Can you give me some hints on how to choose the resistor's value, or what should I change to make it work? Thank you!

This question comes after this question (Bidirectional Logic Translator translates to 2.8V instead of ~5) (The "Switch" is actually the SSR)

CH1 is the command pin of the SSR

schematic

simulate this circuit – Schematic created using CircuitLab

\$\endgroup\$
2
  • \$\begingroup\$ Can you put the SSR where R1 is? \$\endgroup\$
    – user253751
    Sep 11, 2018 at 8:15
  • \$\begingroup\$ What pins of the SSR to put there? And is this enough? or do I have to change something else? \$\endgroup\$ Sep 11, 2018 at 8:17

1 Answer 1

1
\$\begingroup\$

Usually you control a relay by connecting the "coil" where the resistor is in your diagram.

The transistor allows current through the coil when the command signal is on, and blocks current when the command signal is off.

Also don't forget to put a current-limiting resistor before the base of the transistor.

Like this:

schematic

simulate this circuit – Schematic created using CircuitLab

It should work the same way for an SSR.

Addendum: The reverse "freewheeling diode" D1 is not required with an SSR. However it is required when using a mechanical relay. If you are using this circuit with a mechanical relay, connect the diode in reverse-parallel with the relay coil as shown.

\$\endgroup\$
5
  • \$\begingroup\$ Cool, will try this and I'll come back, thanks A LOT! I see that your transistor is another model, hope it doesn't matter. \$\endgroup\$ Sep 11, 2018 at 9:57
  • \$\begingroup\$ @MihaiIonuţ-Cosmin Oh, that was the default type in the circuit editor, I didn't put it there on purpose. I forgot that this circuit editor puts it there by default. I'll remove it. \$\endgroup\$
    – user253751
    Sep 11, 2018 at 10:21
  • \$\begingroup\$ Don't worry, I verified and it's the same thing. Thanks! \$\endgroup\$ Sep 11, 2018 at 10:22
  • \$\begingroup\$ Also I figured I should probably add the reverse diode for completeness, since someone else will read this and use the circuit with a mechanical relay. \$\endgroup\$
    – user253751
    Sep 11, 2018 at 10:25
  • \$\begingroup\$ It worked, with the observation that between The CH1 and the resistor, a zener diode is needed \$\endgroup\$ Sep 11, 2018 at 18:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.