schematic

simulate this circuit – Schematic created using CircuitLab

I have a circuit in Simulink that consist PV array and push-pull converter. The load is a simple resistor and with MPPT I extract the max power from the PV module at any load(resistor value)or Irradiation changes.

At the max power point, the panel voltage=37.9 V and the current= 8.3 A.

The problem is this: When I use load R=533.3333 ohm with MPPT I am getting max power(with the voltage and current above and the duty cycle=30%) from the panel and transmit it to the load with 95% efficiency. The Vout=400V and Pout=300 W.

However, when I changed the load R=200 ohm with mppt I am still getting the same max power from the panel(the duty cycle= 9%) but I can't transmit it to the load. There is a huge voltage drop. (Vout becomes 200 V scale. The voltage drop can be seen at the transformer also) The current is the same as the R=533.333 ohm situation.

The situation is similar with irradiation change. When it drops the Mppt can find the new max power point but at the load, there is a huge power loss.

I think the problem causes because of the capacitors. When I don't use any output capacitor there is no voltage drop anywhere. But I don't know the reason of this problem exactly and how can I solve it. If anybody has an idea and shared with me I would appreciate.

Ps1: the paramaters of the circuit are: Primer turns=100

Seconder turns=1100

Input Capacitor=100e-6 F

Output Capacitor= 47 e-6 F

Output Inductor=1e-6 H

At the final of the project, the input voltage from panel can vary between 30 and 40 V.

PS2: Due to a problem of my computer or the internet I cannot upload any image.

closed as unclear what you're asking by Dave Tweed Sep 14 at 19:12

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    No circuit = no answer. – Andy aka Sep 14 at 15:26
  • I added a schematic from this site. But actually i don't understand this kind of language. I tried to explain everything clearly and the question is long as you can see. Also i had stated that i could not attach any image. But the answer i received "No circuit=no asnwer" :))))) It is interesting and annoying actually. I don't know if there is a specific rule about adding circuit may be there is but i had kindly noted before posting that i could not add anything. Anyway sorry for bothering you. – user391130 Sep 15 at 16:37
  • And "on hold" thing. Hahahahah What is it that you don't understand in the question??? – user391130 Sep 15 at 16:39
  • I solved the problem. A snubber circuit was the lack of system. When I add snubber problem was solved. For people who need an help to a similar problem. – user391130 Sep 18 at 14:56