0
\$\begingroup\$

I have a simple circuit working where I drive a laser module with a mosfet(2SK4017Q), a 10K resistor (gate-source) applying 3.3V on the mosfet gate. Mosfet drain is connected to laser module GND, and 5V applied to laser module Vcc. Laser specifications are: output: 5-10mw, working voltage: 4.5-4.8vdc, working current: 40mA. Microcontroller is a Teensy 3.5.

I wanted to miniaturize this but now I believe I have made a mistake choosing some wrong smd mosfet (2N7002). I say "now", because I have made this circuit to work once, but could not reproduce it again (...) In this thread I am trying to understand what's happening next - see picture.

I have removed the 10K resistor from its place (as shown) so gate is floating (when microcontroller is not sending any signal). Any value of resistor I tried until here produced just very pale light, and forward voltage on laser module terminal was about less than 2V.

Inductance (I hope this is the proper term) happens when I hold a (conductive metallic) screwdriver on the laser module trim pot (picture), and simultaneously another screwdriver on the mosfet gate, laser module light gets vivid again and circuit seems to work as expect. I am not sure how to start to fix it.

enter image description here

\$\endgroup\$
  • \$\begingroup\$ I don't know what the problem is, but it is not "inductance." \$\endgroup\$ – JRE Sep 25 '18 at 8:28
  • \$\begingroup\$ You have the gate of the FET floating. When you touch the gate with one hand and the laser module with the other, the gate is no longer floating. It is either pulled to ground or to V+. Which ever it is, that's what the rest of the circuit on your board needs to do to make the laser light up. \$\endgroup\$ – JRE Sep 25 '18 at 8:31
  • \$\begingroup\$ Thanks for highlighting it to me. The problem could be mosfet needs a higher power on gate (5V). Considering I can't change the microcontroller signal at 3V, or I add a P-FET and another N-FET to control the current N-FET, or I try to find a new N-FET which can switch under 3.3V. \$\endgroup\$ – Bontempos Sep 25 '18 at 13:28
  • \$\begingroup\$ Gate is floating yes, but I am still not sure how my hands interference could be acting on the gate-source threshold in order to allow FET to forward enough voltage to switch on the laser module...since a pull down/up resistor didn't work. Also, the laser module switches on properly only when touching the trim pot DIM terminal... \$\endgroup\$ – Bontempos Sep 25 '18 at 13:28
  • \$\begingroup\$ Try a pull up to 5V on the gate and see if that triggers the laser. I expect the trimmer is connected (maybe indirectly) to 5V. From there, your body (through the tools, through your fingers, through your body) provides the 5V to the gate. Your body can be thought of as a resistor with several kiloohms of resistance. \$\endgroup\$ – JRE Sep 25 '18 at 15:37
0
\$\begingroup\$

Since the comments cleared up the problem, and you've verified that my suggestions were correct, I'll make an answer of them.

First off, is has nothing to do with "inductance." Inductance is associated with coils (also known as inductors.) Your body does act like a mixture of various passive components - it has resistance and capacitance, and if you measure it right it has inductance as well. The most relevant thing here, however, is resistance.

When you touch the gate of the FET with one hand, and the laser module with the other, you are most likely supplying 5V to the gate from the laser through your body.

You need to pull the gate to a higher voltage to make it "switch" properly. 3.3V (which you used previously) isn't high enough to make the 2N7002 conduct well. It is specified at 10V difference between gate and source.

With your hands in there, you are getting 5V from the laser to the gate. That is enough to open up the FET and get the laser lit brightly. Your body is playing the part of the pull up resistor.

3.3V seems to be too little. 5V is better, but I expect the transistor still isn't fully on.

You might ought to look into an FET with a lower Vgs. Maybe one of the "logic level" FETs that are available.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.