3
\$\begingroup\$

I'm trying to program a Cyclone II I bought here using Quartus II 13.0sp1 on Arch Linux. I'm trying to program it with a very simple Verilog program with three inputs and two outputs and a few simple logic functions. I selected the proper model (EP2C5T144C8), assigned the pins to the inputs/outputs, compiled, and ran the programmer. I am using a JTAG USB blaster. When I run jtagconfig, I receive the following output

1) USB-Blaster [2-1.6]
    020B10DD   EP2C5

However, when I try to program the .sof file created by the compiler, I receive the following error.

Error (209015): Can't configure device. Expected JTAG ID code 0x020B10DD for device 1, but found JTAG ID code 0x000310D9.

If I run the programmer multiple times, I often get different values for the ID code that it found. Does anyone know what's wrong here?

\$\endgroup\$
  • \$\begingroup\$ What programmer are you using to program the device? A lot of these low-cost boards are supplied with fake "USB Blaster" JTAG interfaces that may not be quite up to the job -- see e.g. hackaday.io/project/92800-fpga-experiments/log/… \$\endgroup\$ – Jules Oct 5 '18 at 7:36
  • \$\begingroup\$ If you're getting different codes each time, there is either a dodgy connection somewhere, or the device is toast. \$\endgroup\$ – Tom Carpenter Oct 5 '18 at 7:59
  • \$\begingroup\$ @Jules I bought a $10 one thats featured on the same page on Amazon. \$\endgroup\$ – Chris Loonam Oct 5 '18 at 12:41
  • \$\begingroup\$ @TomCarpenter I figure it probably is, but what throws me off is that the device ID in the jtagconfig command shows up properly. \$\endgroup\$ – Chris Loonam Oct 5 '18 at 12:42
3
\$\begingroup\$

It turns out the solution is similar to what I had seen online; it's a power supply problem. Getting a proper 5 V power supply solved the issue, and the FPGA is now programmable and fully functioning.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.