I tried to program specific STM ultra-low power series (STM32L011D4-tssop14). JLink programmer doesn't support this type of STM32 MCUs. so I tried to program this MCU by STLINK-V2 (SW mode). to do this I am doing the following works:

1- connect all wire which needed for this task (GND-VCC-SWDIO-SWCLK)

2- select "option for target..." in Keil 3- going to debug tab and select "ST-link debugger"

4- going to setting => as I know in "SW Device" section I should see the device information but I have an error " NO target Connected ".

that's weird for me when I connect RST pin of MCU to ground "SW Device" section showed device information. in this way, if I push F8 (Load in Keil) error appears "Core is held in reset"

it's reasonable when I force MCU to reset ( connect RST pin to GND) the program process shouldn't work ( "Core is held in reset" ) but if I don't do that programmer cant connect to the micro ("NO target Connected")

I don't know how should I Program this MCU...

  • \$\begingroup\$ You'll likely need to either use programmer software which can do a coordinated manipulation of the reset line, or else do something to prevent the MCU from running code which disables SWD or sleeps; for example, you could use the boot mode pins to make it start up to the ROM bootloader. This is probably a duplicate of one or more previous questions on the subject. \$\endgroup\$ Oct 10, 2018 at 15:09

1 Answer 1


JLink programmer doesn't support this type of STM32 MCUs.

The SEGGER website lists the STM32L011D4 as a supported MCU. Check your jlink software version.

You may need the "connect under Reset" option - don't know where that is in Keil settings. This obviously requires the reset line to be connected to the debugger.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.