I've noticed something that seems odd to me in an LTspice simulation (see below).

I'm trying to model a system with a number of identical devices which each draw ~11W (with negligible variation over different input voltages) and are separated by long cable runs.

When the input voltage is 47.1V or higher then there is 'normal' voltage drop over the run and the last device (B17) would theoretically work happily.

When the input voltage is 47.0V or lower, the simulation shows huge voltage drops resulting very low voltage at the last device.

If anyone could point me in the right direction it would be much appreciated! It could be a quirk of the simulation, a case of garbage-in=garbage-out or a fundamental misunderstanding on my part :-)

47.1V 47V

up vote 0 down vote accepted

It's a failure of the simulation, if you do it as a sweep, the point at which it fails is dependent on both the start point and the step size, which is clearly nonsense.enter image description here

  • Thanks for looking into this - it confirms my suspicions... I'll let you all know if I work out a better way to model the loads that gets around the issue. – MrWhippy Oct 11 at 23:55

Constant power loads are fundamentally problematic.

\$P = IV\$ rearranges to \$ I = \frac{P}{V}\$, so as V tends to zero I tends to infinity.

In other words to get a truly constant power load "off the ground" requires an infinite current. In practice loads are not truly constant power, but the current required to get them "off the ground" can be much higher than the normal operating current.

I'm not familiar with the internals of LTspice but I would guess it uses some form of iterative approach, depending on where it starts from the loads may or may not come "off the ground".

To make a useful overall model you need a better model of your loads, over what range of voltages are they constant power? what is their behaviour at voltages outside of that range. Unfortunately I don't know if there is a way to build custom models in LTspice.

  • Yes, it looks like LTspice's models don't have an innate way around this issue. I'll work out if I can improve my load modelling and let you know if I can find any improvements – MrWhippy Oct 11 at 23:57

You may want to reset LTspice's solver configuration to its default values. I did not see an issue.

enter image description here

  • Thanks for your suggestion. I tried resetting to the defaults but saw no difference. I then ticked "skip initial operating point solution" and found that the model worked normally at 47.0V as you showed. However at 46.5V the problem occurs again! I tried updating my installation of LTspice but that didn't fix the issue either. – MrWhippy Oct 11 at 23:53

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.