1
\$\begingroup\$

I'm currently designing a PCB and I need to use hatched polygons in order to get my PCB produced (my manufacturer accepts only hatched polygons). The problem is the following: in only one of the layers I'm getting those weird squared holes in the hatched polygons

wrong polygon

for the others layers the settings of the hatched polygons are the same, and they look like normal solid copper regions (see the red polygons underneath the wrong one). The settings I'm using are the following:

settings polygons

and if I set "solid(copper region)" this is the result (which is the same that I expect also with the hatched one):

expected polygon

I've checked the polygons rules and everything is as it should, there is no rule concerning only this specific layer. I've also tried to delete and redo the polygon, close and open Altium 17 , and open the project on another computer with a newer version of the software. Have you ever had such problem? Thank you in advance

EDIT:

After playing a bit, since the problem was appearing only in one layer, I tried to copy all the traces and transfer them in a new layer. The problem is relatively disappeared, I'm not getting those holes anymore but now the problem is that close to some pads, there are some small traces not connected to the polygon, as you can see here :

Small traces created together with the polygon

the settings are the same as before, and this is the overall result:

result

this is better than before but stil it is not ideal. I also tried to copy the files in a new project, but the result is still the same.

\$\endgroup\$
  • \$\begingroup\$ The issue might be clearer in single layer display mode (Shift-S) \$\endgroup\$ – Peter Smith Oct 16 '18 at 11:31
  • \$\begingroup\$ I have never seen this issue before. What happens when you uncheck "Remove Dead Copper"? How about changing the dropdown to "Pour over all same net objects"? Does it still look the same? \$\endgroup\$ – DerStrom8 Oct 16 '18 at 11:45
  • \$\begingroup\$ Yes, unfortunately I tried different combinations of settings. The only thing that helps is to modify the track width and grid size, but the holes just get smaller. they don't disappear \$\endgroup\$ – Luca Daidone Oct 16 '18 at 12:17
  • \$\begingroup\$ There may be phantom or very tiny pieces of copper not assigned to the plane. Using single layer view mode, zoom in deeply at a hole and you may see it. I have had this issue a number of times. \$\endgroup\$ – Peter Smith Oct 16 '18 at 15:02
  • \$\begingroup\$ @PeterSmith thank you but I don't think this is the case, I checked and there are not pieces of copper. I'll update the question to add further details I found out. \$\endgroup\$ – Luca Daidone Oct 16 '18 at 15:58
0
\$\begingroup\$

Ok I solved it. Actually the problem was in the clearance rules. In the project there are several clearance rules for different components and basically the problem was the following: the clearance between pad and traces or pad and copper of some components were defined several time (shame on me) and the priorities were set in such a way to have for example a 0.3mm clearance for the rules with the highest and lowest priority, and 0.2mm for the rules with the priority in the middle, so apparently Altium didn't know exactly how to behave. So tidying up the rules solved the problem. Thank you to everyone!

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.