0
\$\begingroup\$

I've recently purchased a cheap eBay DPS3012 DC-DC converter supply. I intend to use it on breadboard projects.

The "problem" is that the meter reads a 5V output, with no current being drawn and therefore no power. However, the LEDs and ICs are working properly. I'm guessing it's something to do with breadboard characteristics.

I'm sure there's a relatively simple answer for this, I have done some research but haven't found a satisfactory answer.

Thanks for the help in advance!

\$\endgroup\$
  • 1
    \$\begingroup\$ What is the resolution of the ammeter? If it only displays down to 0.1A, you aren't going to see that with an LED and a few IC's. \$\endgroup\$ – R Drast Oct 17 '18 at 8:18
  • \$\begingroup\$ "a cheap eBay" well, and then you have question? \$\endgroup\$ – PlasmaHH Oct 17 '18 at 8:18
  • 2
    \$\begingroup\$ I have a cheap eBay current meter. It's biassed so that it reads 0, even up to 10s of mA, presumably so that's it's guarranteed not to show any current flowing when there's no load. Like all cheap eBay stuff, you get what you pay for, and if you're prepared to measure and characterise it, and live with its deficiencies, you can sometimes find excellent value for money that way. \$\endgroup\$ – Neil_UK Oct 17 '18 at 8:28
  • \$\begingroup\$ @RDrast The resolution is 00.00A (microamps) so I expected something. I didn't expect the ICs to draw much but the LEDs should be drawing 20mA each. I have repeatedly and fairly accurately measured down to 0.05A before on this supply. I'll try measuring the current locally from the LED to ground. \$\endgroup\$ – Oleenick Oct 17 '18 at 8:32
  • \$\begingroup\$ Meant mA not uA sorry \$\endgroup\$ – Oleenick Oct 17 '18 at 9:34
3
\$\begingroup\$

These cheap PSU usually have current / voltage reading but they are not by any mean accurate. They are more there to give a rough idea of what current is flowing.

An LED typically draws 10-20mA and your PSU, from the datasheet has a resolution of 0.01A (10mA).

Also the resolution is "what is displayed" and does not represent the actual accuracy of the device, which is probably on the range of 5 to 10% (EDIT in fact 33% measured by OP). At this price, is certainly not calibrated and you can see from the picture the current sense seems to actually be 2 copper wires used as shunt, which shunt value will change with soldering and small change in the wire thickness and length.

To answer your question, the current you are drawing is simply too small for the resolution and accuracy of this device, it probably has some offset, calibration drift, temperature dependencies and everything you can think off.

Try to hookup a 100ohm or less resistor and see if it displays anything.

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ I never thought about it like that. I was mistaken on the microamps bit - just got confused with another datasheet I was reading. I tried drawing more current and it worked. It's just that 15mA looks >10mA to the shunt. I used a 1ohm resistor at 1V and got 75mA of current. \$\endgroup\$ – Oleenick Oct 17 '18 at 9:30
  • 1
    \$\begingroup\$ I'm guess that using Ohms law to find the value of that 1ohm resistor using the 1V and 75mA figures gives 1.33 - definately an imprecision. \$\endgroup\$ – Oleenick Oct 17 '18 at 9:33
  • \$\begingroup\$ now we know what accuracy we can expect from it, +/-33% :P \$\endgroup\$ – Damien Oct 17 '18 at 11:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.