2
\$\begingroup\$

Im attempting for the last 3-4 days to connect the Atmel dev board to the computer in order to either load the .elf or hex file to the bootloader in order to turn on a LED.

Im following instructions based on the online document 'Atmel AVR1916: USB DFU Boot Loader for XMEGA"

The dev board is powering on & I see the menu displayed correctly on the LCD.

My OS is Windows 10, my IDE is Atmel 7 & my device programmer is avr-dude.

These are my steps:

  1. Press SW0 while connecting USB

  2. Connect PC6 to GND while connecting to USB

  3. I tried using Flip to write to the flash & write to the board, however Flip displays error "Could not open USB device".

  4. Initially the dev board shows up as COM port "XPLAINED Virtual Com Port", however after updating the drivers the Windows device manager refreshes and the dev board shows up as "USB Serial Device (COM6)"

  5. I updated the USB Serial Device in Device Manager with USB drivers included with Flip & tried again connecting/finding the device however again Flip displays error "Could not open USB device".

See below:

enter image description here

  1. Then I re-plugged in the USB to make sure that everything & repeated Step 1.

    In Windows Device Manager the dev board is still "USB Serial Device" so Ok.

    I retried several times with Flip until switching to "avr-dude"

  2. Now using AVR dude GUI I tried writing the hex to Flash, in the GUI menu I selected:

    • my target device

    • then I pointed to my .hex that was built via Atmel studio

    • Then in the Setup menu, I tried at atmel available options as device

programmer avr109,avr910,avr911

For avr109 & avr910, I got the following error output:

trying to connect to device... by 1st pressing "verify"
Found programmer: Id = ""; type =
Software Version = . ; Hardware Version = .
Programmer supports the following devices:
Device code: 0x40 = (unknown)
Device code: 0x40 = (unknown)
Device code: 0x40 = (unknown)
Device code: 0x40 = (unknown)
Device code: 0x40 = (unknown)
Device code: 0x40 = (unknown)

For avr911, I got:

trying to connect to device...
Connecting to programmer: .
Found programmer: Id = "@ d"; type =
Software Version = . ; Hardware Version = .
avrdude: error: buffered memory access not supported.

Then I tried programming the device using Atmel 7 studio, therefore I went to Tools menu & Device Programming, but all the options are empty there is no Tools or Devices to select.

I also changed the USB wire just in case.

Please help , what do I need to do to deploy my HEX file to the Atmel "XMEGA-A3BU Xplained" dev board?

I will accept any answer either using Atmel Studio, Flip, or Avr dude.

\$\endgroup\$

migrated from robotics.stackexchange.com Oct 23 '18 at 9:50

This question came from our site for professional robotic engineers, hobbyists, researchers and students.

  • \$\begingroup\$ @sempaiscuba, I tried that but no use. Also got Flip working but flip couldnt see the device either. Note the device actually powers on & the LCD displays correct menu, but Atmel Studio, Flip, or Avr cant communicate with it? \$\endgroup\$ – cyber101 Oct 22 '18 at 3:44
  • \$\begingroup\$ What version of AS7 are you using? After a bit of Googling, I found quite a few reports that the Win10 anniversary edition changed how USB drivers work, which - in turn - caused problems for AS7 with a range of boards (like STLink, for example). From the reports, it seems there might be an updated driver that works available from Microchip/Atmel (some people said this didn't work), or you might need a clean re-install of AS7. \$\endgroup\$ – sempaiscuba Oct 22 '18 at 9:35
  • \$\begingroup\$ @After reinstall AS7 & installing on another computer & also using hardware programmer I found out that the board had issues, AS7 reported that boards voltage was 0.0V which outside of 1.6V to 3.6V required before write operations. The board is powered on with a green light & the LCD is working but the hardware programmer still had issues writing to it. I ordered a new I will update this post ASAP>. \$\endgroup\$ – cyber101 Nov 7 '18 at 2:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.