-1
\$\begingroup\$

I'm trying to repair a speaker of mine (old AudioEngine A5). The encoder that controls the volume is not working properly and turning the volume up REALLY loud sometimes when you touch it.

I had some encoders lying around so thought I would try and replace it, but the newer encoder has one more pin and the names on it are very different.

Any idea what these pins mean, or alternatively where I could source the same encoder?

These are the pins on the broken encoder:

broken encoder

These are the pins on the new encoder:

new encoder

Also, I've tried googling for the part number but nothing turns up. Am I looking at some different type of encoder maybe?

Here's a pic of the part numbers for the broken encoder:

broken encoder part numbers

\$\endgroup\$
10
  • \$\begingroup\$ please post a link to the datasheet for the new encoder .... at least the place where you bought it, if the datasheet is not available \$\endgroup\$
    – jsotola
    Nov 2, 2018 at 18:56
  • \$\begingroup\$ the old encoder pin labels appear to be down, up, switch, ground ..... check with continuity meter ..... if you press the switch spindle, then SW and DG should be connected ..... if you spin one way then UP and DG should become connected intermittently ..... the DN and DG may also become intermittently connected, but out of sync with the UP pin \$\endgroup\$
    – jsotola
    Nov 2, 2018 at 19:03
  • \$\begingroup\$ try connecting CLK to UP ..... DT to DN ..... SW to SW ..... GND to DG \$\endgroup\$
    – jsotola
    Nov 2, 2018 at 19:05
  • \$\begingroup\$ looks similar to: bourns.com/docs/product-datasheets/pec11r.pdf?sfvrsn=bb617cbf_6 \$\endgroup\$
    – glen_geek
    Nov 2, 2018 at 19:08
  • 1
    \$\begingroup\$ It is possible that the original component is not a quadrature rotary encoder but basically just up and down button that are pushed based on rotation direction (based on the pin names being UP and DO[wn]). I believe these are called rotary pulse switches. A quadrature encoder would not work as a replacement in this case. \$\endgroup\$
    – Justme
    Nov 2, 2018 at 20:25

1 Answer 1

0
\$\begingroup\$

The newer one have pull-up resistors on the board. They are connected between the signal pins and + (so between DT, CLK, SW and +). This should not be an issue but do result in all the signals being connected together with 10k ohm resistors. If you wanna be on the safe side you can remove these resistors and it will be exactly the same as the old one.

Then connect as @jsotola commented:

try connecting CLK to UP ..... DT to DN ..... SW to SW ..... GND to DG

\$\endgroup\$
4
  • \$\begingroup\$ Thanks I will be trying this tonight. What exactly do you mean by safe? \$\endgroup\$
    – AndrewVos
    Nov 2, 2018 at 20:17
  • \$\begingroup\$ Safe as in the function should remain the same, nothing will get damaged. @AndrewVos \$\endgroup\$
    – mnhjansson
    Nov 2, 2018 at 21:10
  • \$\begingroup\$ Sadly that didn't work. The switch worked perfectly to turn the speak on and off, but no volume control. \$\endgroup\$
    – AndrewVos
    Nov 2, 2018 at 21:41
  • \$\begingroup\$ You could check if the old component was a rotary pulse switch instead of rotary encoder (my previous comment). Try two standard push buttons, one to DO and DG, another to UP and DG. They should emulate the rotary pulse switch and become volume up and down buttons. (Actually, I tend to think a rotary pulse switch exists to emulate two push buttons in a system). \$\endgroup\$
    – Justme
    Nov 2, 2018 at 22:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.