0
\$\begingroup\$

I've tried several different topologies, such as the full bridge rectifier and the following which I've successfully tested on other simulators.

Circuit

However, on Cadence I always end up getting static like this in the output...

Graph

Just be honest. Is it me? Or is it Cadence.

Edit:

Here is a picture of the circuit in Cadence.

enter image description here

Here is a picture of the output run from 0s to 3750us.

enter image description here

Here is a picture of the output run for 3s total.

enter image description here

\$\endgroup\$
  • \$\begingroup\$ Not familiar with Cadence, but it looks like a configuration problem. You're not providing a sensible input to your circuit, or some device has the wrong or no model attached to it, or maybe you just connected the circuit wrong. \$\endgroup\$ – Hearth Nov 25 '18 at 16:29
  • 1
    \$\begingroup\$ Show a picture of the schematic directly from cadence \$\endgroup\$ – Linkyyy Nov 25 '18 at 16:31
1
\$\begingroup\$

It's hard to tell what the problem is as you don't show the simulation specific parameters which cadence/pspice needs for it to function. But it seems to work fine for me:

enter image description here

enter image description here

\$\endgroup\$
  • \$\begingroup\$ Hmm thats a good circuit there \$\endgroup\$ – snowg Nov 25 '18 at 16:57
  • 1
    \$\begingroup\$ Well. His 10ohm load provides a clue. \$\endgroup\$ – Edgar Brown Nov 25 '18 at 16:59
  • \$\begingroup\$ I like big loads. But why is that 10M there? I've legit stayed up all night tryna get this sucker to work. Also, what library is the transformer he used in? \$\endgroup\$ – snowg Nov 25 '18 at 17:00
  • 1
    \$\begingroup\$ @snowg: Both sides of the transformers needs to be referenced to a ground node for the simulator to be able to work. Therefore you add a big resistor to to ground, so the simulator can do it calculations. Its a simulator quirk. The transformer is formed from two inductors, "L", and with the k_linear parameter to specifiy that they are coupled together. \$\endgroup\$ – Linkyyy Nov 25 '18 at 17:04
4
\$\begingroup\$

It looks to me like you need to use the "earth" symbol somewhere so that 0 volts is defined. At the moment there doesn't appear to be an earth on your circuit but that might be because you've cut-off the picture. Hopefully it's as simple as adding an earth node (as what is required in most simulators).

Try adding it at the junction of the two smoothing caps (1 uF). You might also want to explain why the diodes are "N4007" types instead of "1N4007".

\$\endgroup\$
  • \$\begingroup\$ The image is simply a diagram. That isn't from a circuit I ran through a simulator. I'll test out your suggestion \$\endgroup\$ – snowg Nov 25 '18 at 16:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.