3
\$\begingroup\$

I have a problem: I'm making an Arduino shield that has tracks which are supposed to handle up to 10A (maximum, instantaneous) current (usually it's around 2A, but we want to be on the safe side.

KiCad calculated the according tracks thickness as ~11mm, which is huge for an Arduino Uno shield. Therefore, it was suggested to me to have two tracks on both sides, ~5mm thick each. However, when I connect two nodes with the second track, the original track gets removed, even if I lock it.

How can I get around this?

\$\endgroup\$
4
\$\begingroup\$

When you start the routing tool, you can Right-click and select "Interactive Router Settings". That will bring up the window below.

Then deselect the "Remove Redundant Tracks" option.

Interactive Router Settings

\$\endgroup\$
  • \$\begingroup\$ H*ck, now I feel silly. I tried every setting window, but apparently not this one :D \$\endgroup\$ – Gallifreyan Nov 27 '18 at 19:33
  • \$\begingroup\$ Glad it works for you! If you get a chance, click the "accepted" check mark next to the up/down arrows and that will let people know that the answer helped you find a solution. \$\endgroup\$ – Seth Nov 27 '18 at 19:42
2
\$\begingroup\$

Some PCB programs have an option to automatically remove loops or duplicate connections. Look in Routing or DRC options for this feature, and turn it off.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.