0
\$\begingroup\$

I'm following the example from the top answer of this question.

Here below I exactly do the same thing:

enter image description here

But when I right open Spice Error Log (View -> Spice Error Log), and right click on a place as you see the "Plot Stepped Measured Data" is disabled.

How can I solve this issue?

\$\endgroup\$
  • \$\begingroup\$ Try fixing the warning then moving onto the error if it still occurs. Put a 1M load resistor on output to ground. \$\endgroup\$ – Andy aka Nov 28 '18 at 13:44
  • \$\begingroup\$ The resistor didn't help:( Does it work in yours? Do you get the same issue? \$\endgroup\$ – cm64 Nov 28 '18 at 20:59
1
\$\begingroup\$

Not only your .MEAS is wrong, but I'm used to a different syntax, but you are using undeclared values (n? did you mean t?). Try not to rely on the UI too much and, instead, use the manual, or ltwiki. You would have found out that the proper expression for AVG measurements is (as given in the manual):

.MEAS TRAN res7 AVG V(NS01)
+ TRIG V(NS05) VAL=1.5 TD=1.1u FALL=1
+ TARG V(NS03) VAL=1.5 TD=1.1u FALL=1

Because your directive could not be executed, there were no measured values, and so there's nothing that can be plotted. If you change your .MEAS card to this:

.meas x avg v(x) trig time=t-S/2 targ time=t+S/2

you'll find that it works. Not home right now, but here's the proof:

proof

\$\endgroup\$
  • \$\begingroup\$ I tried it doesn't work. What is x? I tried ti change x to out and still not working. Still disabled. Could you try this circuit i.stack.imgur.com/qp1AW.png and let me see what exactly you write to SPICE directive. \$\endgroup\$ – cm64 Nov 29 '18 at 18:12
  • \$\begingroup\$ Use your node voltage, V(out), not V(x), you don't have anything like that on your schematic. \$\endgroup\$ – a concerned citizen Nov 29 '18 at 18:19
  • \$\begingroup\$ In error log it says Measurement "out" FAIL'ed. My directive is now: .meas out AVG v(out) TRIG time=t-S/2 TARG time=t+S/2 \$\endgroup\$ – cm64 Nov 29 '18 at 18:22
  • \$\begingroup\$ Please if possible try in your LTspice Im curious if it will work for you. \$\endgroup\$ – cm64 Nov 29 '18 at 18:23
  • \$\begingroup\$ It also says: WARNING: Less than two connections to node OUT. This node is used by V2. .OP point found by inspection. \$\endgroup\$ – cm64 Nov 29 '18 at 18:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.