0
\$\begingroup\$

I've bought 10 of TP4056 Lipo charging modules from a Chinese vendor. Tried using them in something I've built, but whenever I plug the power source in, the charge led doesn't light up. In fact it doesn't seem to react at all.

So I googled around and saw I could check it by wiring the module directly to a battery and power source, which I did, but still no reaction from the module. I'm very much new to this and was wondering if I'm doing something wrong and how to know for sure that I got 10 faulty modules, since I already tested 5 of them the same way with the same results.

Attached are the pics of the module and my testing setup - connected to 18650 battery (- to the flat bottom of it, + to the inset top), and power source (tried both computer USB and iphone charger + wall socket.)

Module

Connections

\$\endgroup\$
0
\$\begingroup\$

Well with the TP4056 I've got (bought 5 pack from ali express), the red light only comes on when there is a battery connected to the B+ and B- terminals, and a voltage connected to the input USB/terminals, and switches to blue when the battery is full. When there's an input voltage but no battery, the blue light stays on. It might be that your TP4056s are just build like that, but personally I would check if there's any current being supplied to the battery by connected an ammeter (can use a DMM) in series with any of the battery terminals and its corresponding connection to the battery

schematic

simulate this circuit – Schematic created using CircuitLab

. This way you can see if there's any such current being supplied to it, to test if all boards work. Its unlikely from my experience that all of the boards would be broken, so further testing is advised.

Also, off topic, but I wouldn't connect it to a laptop USB (or even a computer USB if the drawn current is low, a lot of these are 100ma limited). This will charge the battery slowly, or may burn out the USB controller. A wall adapter is much better for these types of things.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.